PHP 7.3.x < 7.3.26 / 7.4.x < 7.4.14 / 8.x < 8.0.1入力検証エラー

medium Nessus プラグイン ID 144947
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、入力検証エラーの影響を受けます。

説明

リモートホストにインストールされているPHPのバージョンは、7.3.26より前の7.3.x、または7.4.14より前の7.4.x、または8.0.1より前の8.xです。
したがって、各修正済みリリースの変更ログで指定されているように、URLの検証が不十分なため、入力検証エラーの影響を受けます。認証されていないリモートの攻撃者がこれを悪用し、「@」文字を含めることでURLフィルターをバイパスする可能性があります。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョンにのみ依存しています。

ソリューション

PHP バージョン 7.3.26、7.4.14、8.0.1 以降にアップグレードしてください。

関連情報

https://www.php.net/ChangeLog-7.php#7.3.26

https://www.php.net/ChangeLog-7.php#7.4.14

https://www.php.net/ChangeLog-8.php#8.0.1

プラグインの詳細

深刻度: Medium

ID: 144947

ファイル名: php_8_0_1.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/1/14

更新日: 2021/2/25

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2020-7071

VPR

リスクファクター: Low

スコア: 1.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/1/7

脆弱性公開日: 2021/1/7

参照情報

CVE: CVE-2020-7071

IAVA: 2021-A-0009-S