Amazon Linux AMI:e2fsprogs(ALAS-2021-1458)

medium Nessus プラグイン ID 144997
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのAmazon Linux AMIホストに、セキュリティ更新プログラムがありません。

説明

リモートホストにインストールされているe2fsprogsのバージョンは1.43.5-2.44より前のです。したがって、ALAS-2021-1458のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- E2fsprogs 1.45.3のクォータファイル機能に、悪用可能なコード実行の脆弱性が存在します。特別に細工されたext4パーティションは、ヒープ上で領域外書き込みを引き起こし、コード実行が発生する可能性があります。攻撃者がパーティションを破損させて、この脆弱性を引き起こす可能性があります。(CVE-2019-5094)

- E2fsprogs e2fsck 1.45.4のディレクトリ再ハッシュ機能に、コード実行の脆弱性が存在します。
特別に細工されたext4ディレクトリは、ヒープ上で領域外書き込みを引き起こし、コード実行が発生する可能性があります。攻撃者がパーティションを破損させて、この脆弱性を引き起こす可能性があります。(CVE-2019-5188)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「yum update e2fsprogs」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/ALAS-2021-1458.html

https://access.redhat.com/security/cve/CVE-2019-5094

https://access.redhat.com/security/cve/CVE-2019-5188

プラグインの詳細

深刻度: Medium

ID: 144997

ファイル名: ala_ALAS-2021-1458.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2021/1/14

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2019-5188

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 4.6

Temporal Score: 3.4

ベクトル: AV:L/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.7

Temporal Score: 5.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:e2fsprogs, p-cpe:/a:amazon:linux:e2fsprogs-debuginfo, p-cpe:/a:amazon:linux:e2fsprogs-devel, p-cpe:/a:amazon:linux:e2fsprogs-libs, p-cpe:/a:amazon:linux:e2fsprogs-static, p-cpe:/a:amazon:linux:libcom_err, p-cpe:/a:amazon:linux:libcom_err-devel, p-cpe:/a:amazon:linux:libss, p-cpe:/a:amazon:linux:libss-devel, cpe:/o:amazon:linux

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/1/12

脆弱性公開日: 2019/9/24

参照情報

CVE: CVE-2019-5094, CVE-2019-5188

ALAS: 2021-1458