IBM HTTP Server 7.0.0.0 <= 7.0.0.41 / 8.0.0.0 < 8.0.0.13 / 8.5.0.0 < 8.5.5.11 / 9.0.0.0 < 9.0.0.2の複数の脆弱性(548231)

critical Nessus プラグイン ID 145061
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは複数の脆弱性の影響を受けます。

説明

リモートホストで実行されているバージョンのIBM HTTP Serverは、Apache HTTP Serverに関連する以下のような複数の脆弱性の影響を受けます。

- 2.1.0 より前の expat の expat/lib/xmlparse.c の poolGrow 関数のメモリ漏洩により、コンテキスト依存の攻撃者が、エンティティ拡張時に不適切に処理された再割り当ての失敗を引き起こす、大量の細工された XML ファイルを通じて、サービス拒否(メモリ消費)を引き起こすことが可能です。
(CVE-2012-1148)

-Expatのオーバーフロー保護は、特定の最適化設定を持つコンパイラーにより削除されています。これにより、リモートの攻撃者は、細工されたXMLデータを通じて、サービス拒否(クラッシュ)を引き起こしたり、任意のコードを実行したりすることができます。注:この脆弱性は、CVE-2015-1283 および CVE-2015-2716 に対する修正が不完全なために存在します。
(CVE-2016-4472)

Expatにより、コンテキスト依存の攻撃者が、バッファオーバーフローを引き起こす無効な形式の入力ドキュメントを介して、サービス拒否(クラッシュ)を引き起こしたり、任意のコードを実行したりする可能性があります。(CVE-2016-0718)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

IBM HTTP Serverのバージョン7.0.0.43、8.0.0.13、8.5.5.11、9.0.0.2以降にアップグレードしてください。または、暫定修正に必要な最低限のFix Packにアップグレードしてから、推奨されている暫定修正を適用してください。

関連情報

https://www.ibm.com/support/pages/node/548231

プラグインの詳細

深刻度: Critical

ID: 145061

ファイル名: ibm_http_server_548231.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

ファミリー: Web Servers

公開日: 2021/1/19

更新日: 2021/1/25

依存関係: ibm_http_server_nix_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2016-0718

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:ibm:http_server

必要な KB アイテム: installed_sw/IBM HTTP Server (IHS)

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/8/16

脆弱性公開日: 2012/7/3

参照情報

CVE: CVE-2012-0876, CVE-2012-1148, CVE-2016-0718, CVE-2016-4472

BID: 52379, 90729, 91528