RHEL 7:OpenShift Container Platform 4.5.27パッケージおよび(RHSA-2021: 0034)

medium Nessus プラグイン ID 145089
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 7ホストにインストールされているパッケージは、RHSA-2021: 0034アドバイザリに記載されている複数の脆弱性の影響を受けます。

- jenkins-2-plugins/subversion:XMLパーサーは、XML外部エンティティ(XXE)攻撃を防止していません(CVE-2020-2304)

- jenkins-2-plugins/mercurial:XMLパーサーは、XML外部エンティティ(XXE)攻撃を防止していません(CVE-2020-2305)

- jenkins-2-plugins/mercurial:HTTPエンドポイントでパーミッションチェックを欠落する情報開示につながる可能性があり(CVE-2020-2306)

- jenkins-2-plugins/kubernetes:Jenkinsコントローラーの環境変数はKubernetesプラグインでアクセス可能です(CVE-2020-2307)

- jenkins-2-plugins/kubernetes:Kubernetesプラグインに権限チェックがないため、ポッドテンプレートを一覧表示できる(CVE-2020-2308)

- jenkins-2-plugins/kubernetes:Kubernetesプラグインに権限チェックがないため、認証情報IDを列挙できる(CVE-2020-2309)

- python-urllib3:HTTPリクエストメソッドによるCRLFインジェクション(CVE-2020-26137)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるjenkins-2-pluginsおよび/またはpython2-urllib3パッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/113.html

https://cwe.mitre.org/data/definitions/200.html

https://cwe.mitre.org/data/definitions/611.html

https://cwe.mitre.org/data/definitions/862.html

https://access.redhat.com/security/cve/CVE-2020-2304

https://access.redhat.com/security/cve/CVE-2020-2305

https://access.redhat.com/security/cve/CVE-2020-2306

https://access.redhat.com/security/cve/CVE-2020-2307

https://access.redhat.com/security/cve/CVE-2020-2308

https://access.redhat.com/security/cve/CVE-2020-2309

https://access.redhat.com/security/cve/CVE-2020-26137

https://access.redhat.com/errata/RHSA-2021:0034

https://bugzilla.redhat.com/1883632

https://bugzilla.redhat.com/1895939

https://bugzilla.redhat.com/1895940

https://bugzilla.redhat.com/1895941

https://bugzilla.redhat.com/1895945

https://bugzilla.redhat.com/1895946

https://bugzilla.redhat.com/1895947

プラグインの詳細

深刻度: Medium

ID: 145089

ファイル名: redhat-RHSA-2021-0034.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2021/1/20

更新日: 2021/10/7

依存関係: ssh_get_info.nasl, redhat_repos.nasl

リスク情報

CVSS スコアのソース: CVE-2020-26137

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 6.4

Temporal Score: 4.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 5.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:jenkins-2-plugins, p-cpe:/a:redhat:enterprise_linux:python2-urllib3

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/1/20

脆弱性公開日: 2020/9/30

参照情報

CVE: CVE-2020-2304, CVE-2020-2305, CVE-2020-2306, CVE-2020-2307, CVE-2020-2308, CVE-2020-2309, CVE-2020-26137

RHSA: 2021:0034

CWE: 113, 200, 611, 862