Jenkins < 2.263.2 LTS/2.275の複数の脆弱性

high Nessus プラグイン ID 145248
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーでホストされているジョブスケジューリング/管理システムは、複数の脆弱性の影響を受けます。

説明

リモートWebサーバーで実行されているJenkinsのバージョンは、2.275より前か、2.263.2より前のJenkins LTSのバージョンです。そのため、以下を含む複数の脆弱性による影響を受けます:

- エージェント/設定の権限を持つユーザーは、2.274以前のバージョンのJenkinsや2.263.1以前のバージョンのLTSを使って、エージェント名を選択することができます。これにより、Jenkinsはグローバル「config.xml」ファイルを上書きします。(CVE-2021-21605)

- 様々なオブジェクトを作成したり構成したりする権限を持つ攻撃者は、2.274以前のバージョンのJenkinsや2.263.1以前のバージョンのLTSを使って、細工されたコンテンツを古いデータモニタに注入することができます。これにより、管理者が破棄した危険なオブジェクトがインスタンス化されます。(CVE-2021-21604)

- 2.274以前のバージョンのJenkinsや2.263.1以前のバージョンのLTSでは、リクエストされたURLをアクセス可能なパスの一覧と一致させないことがあるため、全般/読み取りのアクセス権限を持っていない攻撃者が、そのような権限があるかのようにいくつかのURLにアクセスすることが可能になります。(CVE-2021-21609)

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Jenkinsをバージョン2.275以降に、Jenkins LTSをバージョン2.263.2以降にアップグレードしてください。

関連情報

https://www.jenkins.io/security/advisory/2021-01-13/

プラグインの詳細

深刻度: High

ID: 145248

ファイル名: jenkins_2_274.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/1/22

更新日: 2021/6/3

依存関係: jenkins_detect.nasl

リスク情報

CVSS スコアのソース: CVE-2021-21605

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6

Temporal Score: 4.4

ベクトル: AV:N/AC:M/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:cloudbees:jenkins, cpe:/a:jenkins:jenkins

必要な KB アイテム: www/Jenkins

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/1/13

脆弱性公開日: 2021/1/13

参照情報

CVE: CVE-2021-21602, CVE-2021-21603, CVE-2021-21604, CVE-2021-21605, CVE-2021-21606, CVE-2021-21607, CVE-2021-21608, CVE-2021-21609, CVE-2021-21610, CVE-2021-21611

IAVA: 2021-A-0039-S