pfSense 2.4.x < 2.4.4-p1の複数の脆弱性(SA-18_09)

high Nessus プラグイン ID 146059

概要

リモートのファイアウォールホストは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートのpfSenseのインストールは2.3.4-p1より前のバージョン2.4.xです。そのため、以下を含む複数の脆弱性による影響を受けます:

- Netgate pfSense CE 2.4.4-RELEASEが特定のPOSTリクエストのパラメーターを処理する方法に、悪用可能なコマンドインジェクションの脆弱性があります。攻撃者がこれを悪用して、システムで任意のコマンドを実行する可能性があります。攻撃者は、認証されたPOSTリクエストを管理Webインターフェイスに送信できる必要があります。「powerd_normal_mode」パラメーターでコマンドインジェクションが可能です。(CVE-2018-4019)

- Netgate pfSense CE 2.4.4-RELEASEが特定のPOSTリクエストのパラメーターを処理する方法に、悪用可能なコマンドインジェクションの脆弱性があります。攻撃者がこれを悪用して、システムで任意のコマンドを実行する可能性があります。攻撃者は、認証されたPOSTリクエストを管理Webインターフェイスに送信できる必要があります。「powerd_ac_mode」パラメーターでコマンドインジェクションが可能です。(CVE-2018-4020)

- Netgate pfSense CE 2.4.4-RELEASEが特定のPOSTリクエストのパラメーターを処理する方法に、悪用可能なコマンドインジェクションの脆弱性があります。攻撃者がこれを悪用して、システムで任意のコマンドを実行する可能性があります。攻撃者は、認証されたPOSTリクエストを管理Webインターフェイスに送信できる必要があります。「powerd_battery_mode」POSTパラメーターでコマンドインジェクションが可能です。(CVE-2018-4021)

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

pfSenseバージョン2.4.4-p1以降にアップグレードするか、ベンダーアドバイザリに記載されているパッチを適用してください。

関連情報

http://www.nessus.org/u?a654a213

https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p1.html

プラグインの詳細

深刻度: High

ID: 146059

ファイル名: pfsense_2_4_4_p1.nasl

バージョン: 1.2

タイプ: remote

ファミリー: Firewalls

公開日: 2021/2/2

更新日: 2021/2/3

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 4.8

ベクトル: AV:N/AC:L/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2018-4019

CVSS v3

リスクファクター: High

Base Score: 7.2

Temporal Score: 6.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

必要な KB アイテム: Host/pfSense

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/11/15

脆弱性公開日: 2018/9/28

参照情報

CVE: CVE-2018-4019, CVE-2018-4020, CVE-2018-4021, CVE-2018-6925, CVE-2018-17154, CVE-2018-17155