Apache ActiveMQ 5.x < 5.15.14/5.16.x < 5.16.1の認証バイパス(CVE-2021-26117)

high Nessus プラグイン ID 146087
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストは、認証バイパスの脆弱性の影響を受けるWebアプリケーションを実行しています。

説明

リモートホストで実行中のApache ActiveMQのバージョンは、5.15.14より前の5.x、または5.16.1より前の5.16.xです。したがって、認証バイパスの脆弱性の影響を受けます。オプションのActiveMQ LDAPログインモジュールは、LDAPサーバーへの匿名アクセスを使用するように構成できます。この場合、バージョン5.16.1および5.15.14より前のApache ActiveMQでは、匿名のコンテキストを使用して、有効なユーザーのパスワードを誤って検証するため、パスワードがチェックされません。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache ActiveMQをバージョン5.15.14、5.16.1以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?9ec6690e

プラグインの詳細

深刻度: High

ID: 146087

ファイル名: activemq_5_16_1.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/2/3

更新日: 2021/2/8

依存関係: activemq_web_console_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2021-26117

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:activemq

必要な KB アイテム: installed_sw/ActiveMQ, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/1/17

脆弱性公開日: 2021/1/27

参照情報

CVE: CVE-2021-26117

IAVB: 2021-B-0009