pfSense 2.4.x < 2.4.4-p1の複数の脆弱性

high Nessus プラグイン ID 146206
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのファイアウォールホストは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートのpfSenseのインストールは2.4.5-p1より前のバージョン2.4.xです。したがって、次のサブコンポーネントでセキュリティの脆弱性の影響を受けます:

- 1.10.1以前のUnboundには、ネットワークメッセージボリュームの不十分なコントロールがあります。これは、別名「NXNSAttack」問題です。これは、NSレコードのNSDNAMEにあるランダムなサブドメインによって引き起こされます。(CVE-2020-12662)

- 1.10.1以前のUnboundには、上流サーバーから受信した無効な形式のDNS応答による無限ループがあります。
(CVE-2020-12663)

- 0.14以前のjson-cには、printbuf_memappendで実証されているように、大きなJSONファイル経由の整数オーバーフローと領域外書き込みがあります。(CVE-2020-12762)

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

pfSenseバージョン2.4.5-p1以降にアップグレードするか、ベンダーアドバイザリに記載されているパッチを適用してください。

関連情報

https://docs.netgate.com/pfsense/en/latest/releases/2-4-5-p1.html

プラグインの詳細

深刻度: High

ID: 146206

ファイル名: pfsense_2_4_5_p1.nasl

バージョン: 1.2

タイプ: remote

ファミリー: Firewalls

公開日: 2021/2/4

更新日: 2021/2/5

依存関係: pfsense_detect.nbin

リスク情報

CVSS スコアのソース: CVE-2020-12762

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

必要な KB アイテム: Host/pfSense

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/6/9

脆弱性公開日: 2020/5/9

参照情報

CVE: CVE-2020-12662, CVE-2020-12663, CVE-2020-12762