PHP 7.3.x < 7.3.27 / 7.4.x < 7.4.15 / 8.x < 8.0.2 DoS

high Nessus プラグイン ID 146311
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、サービス拒否の脆弱性による影響を受けます。

説明

リモートホストにインストールされているPHPのバージョンは、7.3.27より前の7.3.x、または7.4.15より前の7.4.x、または8.0.2より前の8.xです。
このため、 SoapClientのnullデリファレンスのために、サービス拒否脆弱性の影響を受けます。認証されていないリモートの攻撃者がこれを悪用し、既存のフィールドなしでXMLをSoapCLient query()関数に提供することで、PHPをクラッシュさせる可能性があります。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョンにのみ依存しています。

ソリューション

PHP バージョン 7.3.27、7.4.15、8.0.2 以降にアップグレードしてください。

関連情報

https://www.php.net/ChangeLog-7.php#7.3.27

https://www.php.net/ChangeLog-7.php#7.4.15

https://www.php.net/ChangeLog-8.php#8.0.2

プラグインの詳細

深刻度: High

ID: 146311

ファイル名: php_8_0_2.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/2/9

更新日: 2021/6/3

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2021-21702

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/2/4

脆弱性公開日: 2021/2/4

参照情報

CVE: CVE-2021-21702

IAVA: 2021-A-0082-S