Apache Flinkローカルファイルインクルードの脆弱性(直接チェック)

high Nessus プラグイン ID 146314
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーで実行されているWebアプリケーションは、ローカルファイルインクルードの脆弱性に影響を受けます。

説明

Apache Flink 1.11.0に導入された変更 (1.11.1および1.11.2でリリースされた変更も含む)により、攻撃者は、JobManagerプロセスのRESTインターフェイスを通して、ローカルファイルシステムのファイルを読み取ることができます。アクセスは、JobManagerプロセスがアクセスできるファイルに制限されています。

ソリューション

Flink1.11.3または1.12.0以降にアップグレードしてください。

関連情報

https://flink.apache.org/security.html

プラグインの詳細

深刻度: High

ID: 146314

ファイル名: apache_flink_cve-2020-17519.nbin

バージョン: 1.5

タイプ: remote

ファミリー: Web Servers

公開日: 2021/2/9

更新日: 2021/4/20

依存関係: apache_flink_webui_detect.nbin

リスク情報

CVSS スコアのソース: CVE-2020-17519

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:flink

必要な KB アイテム: installed_sw/Apache Flink

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/9/18

脆弱性公開日: 2020/1/5

参照情報

CVE: CVE-2020-17519