Adobe Photoshop 21.x < 21.2.5 / 22.x < 22.2 複数の脆弱性(APSB21-10)

high Nessus プラグイン ID 146446
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートWindowsホストにインストールされているAdobe Photoshopは、複数の脆弱性による影響を受けます。

説明

リモート Windows ホストにインストールされている Adobe Photoshop のバージョンは、21.2.5/22.2より前です。したがって、apsb21-10のアドバイザリに記載されている複数の脆弱性の影響を受けます。

-Adobe Photoshopバージョン21.2.4(およびそれ以前)、22.1.1(およびそれ以前)は、領域外書き込みの脆弱性の影響を受けます。認証されていない攻撃者がこの脆弱性を利用し、現在のユーザーのコンテキストで任意コードを実行する可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2021-21047)

- Adobe Photoshop versions 21.2.4(およびそれ以前)、22.1.1(およびそれ以前)は、特別に細工されたファイルを解析する際にメモリ破損の脆弱性の影響を受けます。認証されていない攻撃者がこの脆弱性を利用し、現在のユーザーのコンテキストで任意コードを実行する可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります(CVE-2021-21048)

- Adobe Photoshop versions 21.2.4(およびそれ以前)、22.1.1(およびそれ以前)は、特別に細工されたファイルを解析する際に領域外読み取りの脆弱性の影響を受けます。認証されていない攻撃者がこの脆弱性を利用し、現在のユーザーのコンテキストで任意コードを実行する可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2021-21049、CVE-2021-21050)

- Adobe Photoshop versions 21.2.4(およびそれ以前)、22.1.1(およびそれ以前)は、特別に細工されたファイルを解析する際にバッファオーバーフローの脆弱性の影響を受けます。認証されていない攻撃者がこの脆弱性を利用し、現在のユーザーのコンテキストで任意コードを実行する可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2021-21051)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Adobe Photoshop バージョン21.2.5/22.2またはそれ以降にアップグレードしてください。

関連情報

https://helpx.adobe.com/security/products/photoshop/apsb21-10.html

プラグインの詳細

深刻度: High

ID: 146446

ファイル名: adobe_photoshop_apsb21-10.nasl

バージョン: 1.6

タイプ: local

エージェント: windows

ファミリー: Windows

公開日: 2021/2/12

更新日: 2021/6/3

依存関係: adobe_photoshop_installed.nasl

リスク情報

CVSS スコアのソース: CVE-2021-21051

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 6.9

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:adobe:photoshop

必要な KB アイテム: installed_sw/Adobe Photoshop, SMB/Registry/Enumerated

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/2/9

脆弱性公開日: 2021/2/9

参照情報

CVE: CVE-2021-21047, CVE-2021-21048, CVE-2021-21049, CVE-2021-21050, CVE-2021-21051

IAVA: 2021-A-0076-S