Amazon Linux 2:perl(ALAS-2021-1610)

high Nessus プラグイン ID 146623
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのAmazon Linux 2ホストにセキュリティ更新プログラムがありません。

説明

リモートのホストにインストールされているperlのバージョンは、5.16.3-299より前です。したがって、ALAS2-2021-1610のアドバイザリに記載されている複数の脆弱性の影響を受けます。

32ビットプラットフォーム上の5.30.3より前のPerlでは、ネストされた正規表現修飾子に整数オーバーフローがあるため、ヒープベースのバッファオーバーフローが発生する可能性があります。(CVE-2020-10543)

5.30.3以前のPerlには、「PL_regkind[OP(n)] == NOTHING」状況の誤った処理に関連する整数オーバーフローがあります。細工された正規表現が、命令インジェクションの可能性がある無効な形式のバイトコードにつながる可能性があります。 (CVE-2020-10878)

-5.30.3の前のPerlのregcomp.cは、再帰S_study_chunkコールが原因で、細工された正規表現を介してバッファオーバーフローを起こす可能性があります。(CVE-2020-12723)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「yum update perl」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2/ALAS-2021-1610.html

https://access.redhat.com/security/cve/CVE-2020-10543

https://access.redhat.com/security/cve/CVE-2020-10878

https://access.redhat.com/security/cve/CVE-2020-12723

プラグインの詳細

深刻度: High

ID: 146623

ファイル名: al2_ALAS-2021-1610.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2021/2/19

更新日: 2021/2/19

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-10878

VPR

リスクファクター: Medium

スコア: 5.5

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.6

Temporal Score: 7.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:perl, p-cpe:/a:amazon:linux:perl-CPAN, p-cpe:/a:amazon:linux:perl-ExtUtils-CBuilder, p-cpe:/a:amazon:linux:perl-ExtUtils-Embed, p-cpe:/a:amazon:linux:perl-ExtUtils-Install, p-cpe:/a:amazon:linux:perl-IO-Zlib, p-cpe:/a:amazon:linux:perl-Locale-Maketext-Simple, p-cpe:/a:amazon:linux:perl-Module-CoreList, p-cpe:/a:amazon:linux:perl-Module-Loaded, p-cpe:/a:amazon:linux:perl-Object-Accessor, p-cpe:/a:amazon:linux:perl-Package-Constants, p-cpe:/a:amazon:linux:perl-Pod-Escapes, p-cpe:/a:amazon:linux:perl-Time-Piece, p-cpe:/a:amazon:linux:perl-core, p-cpe:/a:amazon:linux:perl-debuginfo, p-cpe:/a:amazon:linux:perl-devel, p-cpe:/a:amazon:linux:perl-libs, p-cpe:/a:amazon:linux:perl-macros, p-cpe:/a:amazon:linux:perl-tests, cpe:/o:amazon:linux:2

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/2/19

脆弱性公開日: 2020/6/5

参照情報

CVE: CVE-2020-10543, CVE-2020-10878, CVE-2020-12723

ALAS: 2021-1610