openSUSEセキュリティ更新プログラム:qemu(openSUSE-2021-363)

high Nessus プラグイン ID 146938

言語:

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

このqemuの更新では、次の問題が修正されます:

- virtfsの潜在的な権限昇格を修正しました(CVE-2021-20181 bsc#1182137)

- iscsiの領域外アクセスを修正しました(CVE-2020-11947 bsc#1180523)

- vmxnet3エミュレーションの領域外アクセスを修正しました(CVE-2021-20203 bsc#1181639)

- ARM割り込み処理の領域外アクセスを修正しました(CVE-2021-20221 bsc#1181933)

- s390上のvfio-pciデバイスがエラー状態になる問題を修正しました(bsc#1179717 bsc#1179719)

- qemu-guest-agentの更新中に発生する「Failed to try-restart [email protected]」エラーを修正しました。(bsc#1178565)

- より適切なステータスコードの使用など、タイムアウトおよびエラー状態に関するqemu scsiパススルーに修正を適用します。これらの問題の追跡に役立つ、qemuトレースを追加します(bsc#1178049)

この更新はSUSEからインポートされました:SLE-15-SP2: 更新プロジェクトを更新します。

ソリューション

影響を受けるQemuパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1178049

https://bugzilla.opensuse.org/show_bug.cgi?id=1178565

https://bugzilla.opensuse.org/show_bug.cgi?id=1179717

https://bugzilla.opensuse.org/show_bug.cgi?id=1179719

https://bugzilla.opensuse.org/show_bug.cgi?id=1180523

https://bugzilla.opensuse.org/show_bug.cgi?id=1181639

https://bugzilla.opensuse.org/show_bug.cgi?id=1181933

https://bugzilla.opensuse.org/show_bug.cgi?id=1182137

プラグインの詳細

深刻度: High

ID: 146938

ファイル名: openSUSE-2021-363.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2021/3/2

更新日: 2021/6/8

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: Medium

Base Score: 6.9

Temporal Score: 5.1

ベクトル: AV:L/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-20181

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:qemu, p-cpe:/a:novell:opensuse:qemu-arm, p-cpe:/a:novell:opensuse:qemu-arm-debuginfo, p-cpe:/a:novell:opensuse:qemu-audio-alsa, p-cpe:/a:novell:opensuse:qemu-audio-alsa-debuginfo, p-cpe:/a:novell:opensuse:qemu-audio-pa, p-cpe:/a:novell:opensuse:qemu-audio-pa-debuginfo, p-cpe:/a:novell:opensuse:qemu-audio-sdl, p-cpe:/a:novell:opensuse:qemu-audio-sdl-debuginfo, p-cpe:/a:novell:opensuse:qemu-block-curl, p-cpe:/a:novell:opensuse:qemu-block-curl-debuginfo, p-cpe:/a:novell:opensuse:qemu-block-dmg, p-cpe:/a:novell:opensuse:qemu-block-dmg-debuginfo, p-cpe:/a:novell:opensuse:qemu-block-gluster, p-cpe:/a:novell:opensuse:qemu-block-gluster-debuginfo, p-cpe:/a:novell:opensuse:qemu-block-iscsi, p-cpe:/a:novell:opensuse:qemu-block-iscsi-debuginfo, p-cpe:/a:novell:opensuse:qemu-block-nfs, p-cpe:/a:novell:opensuse:qemu-block-nfs-debuginfo, p-cpe:/a:novell:opensuse:qemu-block-rbd, p-cpe:/a:novell:opensuse:qemu-block-rbd-debuginfo, p-cpe:/a:novell:opensuse:qemu-block-ssh, p-cpe:/a:novell:opensuse:qemu-block-ssh-debuginfo, p-cpe:/a:novell:opensuse:qemu-debuginfo, p-cpe:/a:novell:opensuse:qemu-debugsource, p-cpe:/a:novell:opensuse:qemu-extra, p-cpe:/a:novell:opensuse:qemu-extra-debuginfo, p-cpe:/a:novell:opensuse:qemu-guest-agent, p-cpe:/a:novell:opensuse:qemu-guest-agent-debuginfo, p-cpe:/a:novell:opensuse:qemu-ipxe, p-cpe:/a:novell:opensuse:qemu-ksm, p-cpe:/a:novell:opensuse:qemu-kvm, p-cpe:/a:novell:opensuse:qemu-lang, p-cpe:/a:novell:opensuse:qemu-linux-user, p-cpe:/a:novell:opensuse:qemu-linux-user-debuginfo, p-cpe:/a:novell:opensuse:qemu-linux-user-debugsource, p-cpe:/a:novell:opensuse:qemu-microvm, p-cpe:/a:novell:opensuse:qemu-ppc, p-cpe:/a:novell:opensuse:qemu-ppc-debuginfo, p-cpe:/a:novell:opensuse:qemu-s390, p-cpe:/a:novell:opensuse:qemu-s390-debuginfo, p-cpe:/a:novell:opensuse:qemu-seabios, p-cpe:/a:novell:opensuse:qemu-sgabios, p-cpe:/a:novell:opensuse:qemu-testsuite, p-cpe:/a:novell:opensuse:qemu-tools, p-cpe:/a:novell:opensuse:qemu-tools-debuginfo, p-cpe:/a:novell:opensuse:qemu-ui-curses, p-cpe:/a:novell:opensuse:qemu-ui-curses-debuginfo, p-cpe:/a:novell:opensuse:qemu-ui-gtk, p-cpe:/a:novell:opensuse:qemu-ui-gtk-debuginfo, p-cpe:/a:novell:opensuse:qemu-ui-sdl, p-cpe:/a:novell:opensuse:qemu-ui-sdl-debuginfo, p-cpe:/a:novell:opensuse:qemu-ui-spice-app, p-cpe:/a:novell:opensuse:qemu-ui-spice-app-debuginfo, p-cpe:/a:novell:opensuse:qemu-vgabios, p-cpe:/a:novell:opensuse:qemu-vhost-user-gpu, p-cpe:/a:novell:opensuse:qemu-vhost-user-gpu-debuginfo, p-cpe:/a:novell:opensuse:qemu-x86, p-cpe:/a:novell:opensuse:qemu-x86-debuginfo, cpe:/o:novell:opensuse:15.2

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/3/1

脆弱性公開日: 2020/12/31

参照情報

CVE: CVE-2020-11947, CVE-2021-20181, CVE-2021-20203, CVE-2021-20221