Apache Tomcat 8.5.0 < 8.5.63の複数の脆弱性

high Nessus プラグイン ID 147019
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのApache Tomcatサーバーは、複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているTomcatのバージョンは8.5.63より前です。したがって、ベンダーのアドバイザリに記載されている複数の脆弱性の影響を受けます。

-新しいh2c接続リクエストに応答する際、Apache Tomcatバージョン10.0.0-M1から10.0.0、9.0.0.M1から9.0.41、および8.5.0から8.5.61は、あるリクエストからのリクエストヘッダー、および限られた量のリクエスト本文を複写する可能性があります。つまり、ユーザーAとユーザーBの両方が、ユーザーAのリクエストの結果を確認する可能性があるということです。(CVE-2021-25122)

-Apache Tomcat 10.0.0-M1から10.0.0、9.0.0.M1から 9.0.41、8.5.0から8.5.61または7.0.0から7.0.107を使用される可能性が非常に低い構成エッジケースと共に使用する場合、Tomcatインスタンスは依然としてCVE-2020-9494に対して脆弱でした。注意:以前に公開されたCVE-2020-9484の前提条件と以前に公開されたCVE-2020-9484の緩和策の両方が、この問題にも適用されます。(CVE-2021-25329)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache Tomcatバージョン8.5.63以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?b6278e74

http://www.nessus.org/u?0be223a3

http://www.nessus.org/u?15b6baad

プラグインの詳細

深刻度: High

ID: 147019

ファイル名: tomcat_8_5_63.nasl

バージョン: 1.6

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2021/3/4

更新日: 2021/7/16

依存関係: tomcat_error_version.nasl, tomcat_win_installed.nbin, apache_tomcat_nix_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2021-25122

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/1/28

脆弱性公開日: 2021/2/2

参照情報

CVE: CVE-2021-25122, CVE-2021-25329

IAVA: 2021-A-0114-S