Node.js 10.x < 10.24.0 / 12.x < 12.21.0 / 14.x < 14.16.0 / 15.x < 15.10.0 複数の脆弱性

high Nessus プラグイン ID 147145
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

Node.js - JavaScript Runtime Environmentは複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているNode.jsのバージョンは、10.24.0より前の10.x、12.21.0より前の12.x、14.16.0より前の14.x、または15.10.0より前の15.xです。したがって、2021年2月のsecurity-releasesのアドバイザリに記載されている複数の脆弱性の影響を受けます。

- 10.24.0、12.21.0、14.16.0、15.10.0より前のNode.jsのバージョンは、「unknownProtocol」との接続試行が多すぎる場合、サービス拒否攻撃に対して脆弱です。これは、ファイル記述子の漏洩を引き起こします。ファイル記述子の制限が悪意を持って構成されている場合、これによりサーバーが新しい接続を受け入れないか、新しいファイルを開くことができる可能性があります。ファイル記述子の制限が構成されていない場合、これは過剰なメモリ使用につながり、システムがメモリを使い果たす可能性があります。(CVE-2021-22883)

- 10.24.0、12.21.0、14.16.0、15.10.0より前のNode.jsバージョンは、ホワイトリストに「localhost6」が含まれている場合、DNSリバインド攻撃に対して脆弱です。「localhost6」が/ etc / hostsに存在しない場合、通常のドメインのみがネットワーク上のDNSを介して解決されます。攻撃者が被害者のDNSサーバーをコントロールしたり、その応答をスプーフィングしたりできる場合、「localhost6」ドメインを使用することで、DNSリバインド保護がバイパスされる可能性があります。攻撃者が「localhost6」ドメインを使用している限り、攻撃者は CVE-2018-7160説明されている攻撃を依然として適用できます。(CVE-2021-22884)

- 10.24.0、12.21.0、14.16.0、15.10.0より前のNode.jsバージョンのEVP_CipherUpdate、EVP_EncryptUpdateおよびEVP_DecryptUpdateへの呼び出しは、入力長がプラットフォーム上の整数の最大許容長さに近い場合、出力長引数をオーバーフローすることがあります。このような場合、関数呼び出しからの戻り値は1(成功を示す)になりますが、出力の長さの値は負になります。これにより、アプリケーションが不適切に動作したり、クラッシュしたりする可能性があります。(CVE-2021-23840)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Node.jsのバージョンを 10.24.0 / 12.21.0 / 14.16.0 / 15.10.0 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?5bac8db3

プラグインの詳細

深刻度: High

ID: 147145

ファイル名: nodejs_2021_feb.nasl

バージョン: 1.4

タイプ: local

エージェント: windows, macosx, unix

ファミリー: Misc.

公開日: 2021/3/5

更新日: 2021/3/19

依存関係: macosx_nodejs_installed.nbin, nodejs_win_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2021-22884

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 5.1

Temporal Score: 3.8

ベクトル: AV:N/AC:H/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:nodejs:node.js

必要な KB アイテム: installed_sw/Node.js

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/2/23

脆弱性公開日: 2021/2/23

参照情報

CVE: CVE-2021-22883, CVE-2021-22884, CVE-2021-23840

IAVB: 2021-B-0012