Oracle Linux 6:openssl(ELSA-2021-9137)

medium Nessus プラグイン ID 148133
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのOracle Linuxホストにセキュリティ更新プログラムがありません。

説明

リモートのOracle Linux 6ホストに、ELSA-2021-9137アドバイザリに記載されている脆弱性の影響を受けるパッケージがインストールされています。

- X.509 GeneralName型は、さまざまなタイプの名前を表現するための汎用型です。それらの名前の型の一つがEDIPartyNameとして知られています。OpenSSLはGENERAL_NAME_cmp関数を提供しており、GENERAL_NAMEの異なるインスタンスを比較して、それらが等しいかどうかを確認します。この関数は両方のGENERAL_NAMEがEDIPARTYNAMEを含んでいるときに正しく動作しません。NULLポインターディファレンスが発生し、クラッシュが発生してサービス拒否攻撃を受ける可能性があります。OpenSSL自体は、次の2つの目的でGENERAL_NAME_cmp関数を使用します。1)使用可能なCRLとX509証明書に埋め込まれたCRL配布ポイント間のCRL配布ポイント名の比較。2)タイムスタンプ応答トークン署名者がタイムスタンプ機関名と一致することを確認する場合。(API関数TS_RESP_verify_responseおよびTS_RESP_verify_tokenを介して公開)攻撃者が比較される両方のアイテムを制御できる場合、その攻撃者はクラッシュを引き起こす可能性があります。たとえば、攻撃者がクライアントやサーバーをtrickして、悪意のあるCRLに対して悪意のある証明書をチェックさせると、これが発生する可能性があります。注意:一部のアプリケーションは、証明書に埋め込まれたURLに基づいてCRLを自動的にダウンロードします。このチェックは、証明書とCRLの署名が検証される前に行われます。
OpenSSLのs_server、s_client、および検証ツールは、CRLの自動ダウンロードを実装する-crl_downloadオプションをサポートしており、この攻撃はこれらのツールに対して機能することが実証されています。関連のないバグとは、影響を受けるバージョンのOpenSSLがEDIPARTYNAMEの正しいエンコーディングを解析または構築できないことを意味します。ただし、OpenSSLのパーサーが受け入れる無効な形式のEDIPARTYNAMEが構築され、この攻撃が発生する可能性があります。OpenSSLのすべてのバージョン1.1.1および1.0.2は、この問題の影響を受けます。
他のOpenSSLリリースはサポート対象外であり、チェックされていません。OpenSSL 1.1.1iで修正されました(1.1.1-1.1.1hが影響を受けます)。OpenSSL 1.0.2xで修正されました(1.0.2~1.0.2wが影響を受けます)。(CVE-2020-1971)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://linux.oracle.com/errata/ELSA-2021-9137.html

プラグインの詳細

深刻度: Medium

ID: 148133

ファイル名: oraclelinux_ELSA-2021-9137.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2021/3/26

更新日: 2021/3/30

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-1971

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.9

Temporal Score: 5.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:oracle:linux:6, p-cpe:/a:oracle:linux:openssl, p-cpe:/a:oracle:linux:openssl-devel, p-cpe:/a:oracle:linux:openssl-perl, p-cpe:/a:oracle:linux:openssl-static

必要な KB アイテム: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/3/26

脆弱性公開日: 2020/12/8

参照情報

CVE: CVE-2020-1971