Tenable SecurityCenter5.13.x < 5.18.0のDoS(TNS-2021-06)

medium Nessus プラグイン ID 148280
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストにインストールされているアプリケーションは、サービス拒否の脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートホストにインストールされているTenable SecurityCenterアプリケーションはバージョン5.13.x < 5.18.0であり、次のOpenSSLサービス拒否の脆弱性の影響を受けます。

- 悪意を持って細工された再ネゴシエーションのClientHelloメッセージがクライアントから送信された場合、OpenSSL TLSサーバーがクラッシュする可能性があります。TLSv1.2再ネゴシエーションClientHelloでsignature_algorithms拡張(初期のClientHelloに存在)が省略されているが、signature_algorithms_cert拡張が含まれている場合、NULLポインターデリファレンスが発生し、クラッシュとサービス拒否攻撃が引き起こされる可能性があります。サーバーは、TLSv1.2と再ネゴシエーションが有効になっている場合(デフォルトの構成)にのみ脆弱です。OpenSSL TLSクライアントは、この問題の影響を受けません。OpenSSLのすべてのバージョン1.1.1は、この問題の影響を受けます。これらのバージョンのユーザーは、OpenSSL 1.1.1kにアップグレードする必要があります。OpenSSL 1.0.2は、この問題の影響を受けません。OpenSSL 1.1.1kで修正されました(1.1.1-1.1.1jが影響を受けます)。(CVE-2021-3449)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Tenable SecurityCenter 5.18.0以降にアップグレードしてください。

関連情報

https://www.openssl.org/news/secadv/20210325.txt

https://www.tenable.com/security/tns-2021-06

プラグインの詳細

深刻度: Medium

ID: 148280

ファイル名: securitycenter_openssl_1_1_1k_tns_2021_03.nasl

バージョン: 1.4

タイプ: combined

エージェント: unix

ファミリー: Misc.

公開日: 2021/4/1

更新日: 2021/4/9

依存関係: securitycenter_installed.nbin, securitycenter_detect.nbin

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2021-3449

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.9

Temporal Score: 5.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:tenable:securitycenter, cpe:/a:openssl:openssl

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/4/1

脆弱性公開日: 2021/4/1

参照情報

CVE: CVE-2021-3449

IAVA: 2021-A-0149