Mozilla Thunderbird < 78.10

high Nessus プラグイン ID 148772

概要

リモートのmacOSまたはMac OS Xホストにインストールされているメールクライアントは、複数の脆弱性の影響を受けます。

説明

リモートのmacOSまたはMac OS XのホストにインストールされているThunderbirdのバージョンは、78.10より前です。したがって、mfsa2021-14アドバイザリに記載されている複数の脆弱性の影響を受けます。

- WebGLフレームバッファが十分初期化されておらず、メモリ破損と領域外書き込みが発生していました。(CVE-2021-23994)

- レスポンシブデザインモードが有効な場合、以前解放されたオブジェクトへの参照が使用されていました。十分な労力をもってすれば、これを悪用し、任意のコードを実行することが可能と考えられます。(CVE-2021-23995)

- 新しいウィンドウでの複雑なナビゲーションを通じて、HTTPページがHTTPSページから安全なロックアイコンを継承する可能性がありました。(CVE-2021-23998)

- スリップストリームの研究に基づいたさらなる技術が悪意のあるWebページと組み合わされることにより、内部ネットワークのホストおよびユーザーのローカルマシンで実行されているサービスの両方を漏洩していた可能性があります。
(CVE-2021-23961)

- 何らかの異常なユーザーインタラクションを介してBlob URLがロードされた場合、システムプリンシパルによってロードされ、Webコンテンツに付与すべきでない追加の権限が付与された可能性があります。(CVE-2021-23999)

- ユーザーが、エンコードされた改行文字(%0Aおよび%0D)を含むFTP URLをクリックすると、改行はそのように解釈され、任意のコマンドをFTPサーバーに送信できます。
(CVE-2021-24002)

- WebAssembly JITは戻り値の型のサイズを間違って計算する可能性があります。これにより、null読み取りが発生し、クラッシュが発生する可能性があります。注:この問題は、x86-32プラットフォームにのみ影響します。他のプラットフォームは影響を受けません。
(CVE-2021-29945)

- 16ビット整数の境界を超える整数オーバーフローとして書き込まれたポートは、Alt-Svcヘッダーで使用される際に、ポートブロック制限をバイパスする可能性がありました。(CVE-2021-29946)

- 署名は検証前にディスクに書き込まれ、検証中に読み取られます。これは、悪意のあるローカルプロセスまたはユーザーがファイルを置換する際の競合状態にある可能性があります。(CVE-2021-29948)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Mozilla Thunderbirdをバージョン78.10以降にアップグレードしてください。

関連情報

https://www.mozilla.org/en-US/security/advisories/mfsa2021-14/

プラグインの詳細

深刻度: High

ID: 148772

ファイル名: macos_thunderbird_78_10.nasl

バージョン: 1.4

タイプ: local

エージェント: macosx

公開日: 2021/4/19

更新日: 2021/6/28

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2021-29946

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:mozilla:thunderbird

必要な KB アイテム: MacOSX/Thunderbird/Installed

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/4/19

脆弱性公開日: 2021/1/26

参照情報

CVE: CVE-2021-23961, CVE-2021-23994, CVE-2021-23995, CVE-2021-23998, CVE-2021-23999, CVE-2021-24002, CVE-2021-29945, CVE-2021-29946, CVE-2021-29948