MariaDB 10.4.0 < 10.4.18の脆弱性

high Nessus プラグイン ID 148827

概要

リモートのデータベースサーバーは、脆弱性の影響を受けます。

説明

リモートホストにインストールされているMariaDBのバージョンは、10.4.18より前です。したがって、mdb-10418-rnのアドバイザリに記載されている脆弱性の影響を受けます。

- 10.2.37より前のMariaDB 10.2、10.3.28より前の10.3、10.4.18より前の10.4、および10.5.9より前の10.5、2021年3月3日までのPercona Server、およびMySQL用の2021年3月3日までのwsrepパッチで、リモートコードが実行される問題が見つかりました。信頼できない検索パスは、evalインジェクションを引き起こします。データベースSUPERユーザーは、wsrep_providerとwsrep_notify_cmdを変更した後に、OSコマンドを実行できます。注:これは、Oracle製品には影響しません。(CVE-2021-27928)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

MariaDBバージョン 10.4.18以降にアップグレードしてください。

関連情報

https://mariadb.com/kb/en/mdb-10418-rn

プラグインの詳細

深刻度: High

ID: 148827

ファイル名: mariadb_10_4_18.nasl

バージョン: 1.3

タイプ: remote

ファミリー: Databases

公開日: 2021/4/20

更新日: 2021/4/21

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2021-27928

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 7

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.2

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:mariadb:mariadb

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/2/22

脆弱性公開日: 2021/3/19

参照情報

CVE: CVE-2021-27928