WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20

medium Nessus プラグイン ID 148844
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPアプリケーションは、複数の脆弱性の影響を受けます。

説明

WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20は複数の脆弱性の盛況を受けます:

- ファイル(作者など)をアップロードできるユーザーが、メディアライブラリのXML解析問題を悪用して、XXE攻撃を引き起こす可能性があります。これには、PHP8を使用するWordPressのインストールが必要です。XXE攻撃が成功すると、内部ファイルにアクセスできる可能性があります。(CVE-2021-29447)

- WordPressエディターのブロックの1つが、パスワード保護された投稿やページを露出する方法で悪用される可能性があります。これには、少なくともcontributor権限が必要です。(CVE-2021-29450)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

WordPressバージョン5.7.1、5.6.3、5.5.4、5.4.5、5.3.7、5.2.10、5.1.9、5.0.12、4.9.17、4.8.16、4.7.10以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?00aa3f86

https://wordpress.org/support/wordpress-version/version-5-7-1/

https://wordpress.org/download/releases/

プラグインの詳細

深刻度: Medium

ID: 148844

ファイル名: wordpress_5_7_1.nasl

バージョン: 1.8

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/4/20

更新日: 2021/9/16

依存関係: wordpress_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2021-29450

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 4

Temporal Score: 3.1

ベクトル: AV:N/AC:L/Au:S/C:P/I:N/A:N

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:wordpress:wordpress

必要な KB アイテム: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/4/15

脆弱性公開日: 2021/4/15

参照情報

CVE: CVE-2021-29447, CVE-2021-29450

IAVA: 2021-A-0182-S