Ubuntu 16.04 LTS/18.04 LTS/20.04 LTS/20.10:GStreamer Good Pluginsの脆弱性(USN-4928-1)

high Nessus プラグイン ID 149055
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートUbuntuホストに1つ以上のセキュリティ更新がありません。

説明

リモートのUbuntu 16.04 LTS/18.04 LTS/20.04 LTS/20.10ホストには、USN-4928-1のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 1.18.4より前のGStreamerは、特定の無効な形式のMatroskaファイルを分離する際に、エラーコードパスですでに解放されているメモリにアクセスする可能性があります。(CVE-2021-3497)

- 1.18.4より前のGStreamerは、特定の不正な形式のMatroskaファイルを解析する際に、ヒープ破損を引き起こす可能性があります。
(CVE-2021-3498)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://ubuntu.com/security/notices/USN-4928-1

プラグインの詳細

深刻度: High

ID: 149055

ファイル名: ubuntu_USN-4928-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2021/4/29

更新日: 2021/6/7

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2021-3498

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, p-cpe:/a:canonical:ubuntu_linux:gstreamer1.0-gtk3, p-cpe:/a:canonical:ubuntu_linux:gstreamer1.0-plugins-good, p-cpe:/a:canonical:ubuntu_linux:gstreamer1.0-pulseaudio, p-cpe:/a:canonical:ubuntu_linux:gstreamer1.0-qt5, p-cpe:/a:canonical:ubuntu_linux:libgstreamer-plugins-good1.0-0, p-cpe:/a:canonical:ubuntu_linux:libgstreamer-plugins-good1.0-dev

必要な KB アイテム: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/4/28

脆弱性公開日: 2021/4/19

参照情報

CVE: CVE-2021-3497, CVE-2021-3498

USN: 4928-1