Ubuntu 16.04 LTS/18.04 LTS/20.04 LTS/20.10/21.04:Bindの脆弱性(USN-4929-1)

critical Nessus プラグイン ID 149092
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートUbuntuホストに1つ以上のセキュリティ更新がありません。

説明

リモートのUbuntu 16.04 LTS/18.04 LTS/20.04 LTS/20.10/21.04ホストには、USN-4929-1のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- BIND 9.8.5 -> 9.8.8、9.9.3 -> 9.11.29、9.12.0 -> 9.16.13およびバージョンBIND 9.9.3-S1 -> 9.11.29-S1および9.16.8-S1 -> 9.16.13-S1のBIND 9 Supported Preview Edition、ならびにBIND 9.17開発ブランチのリリースバージョン9.17.0 -> 9.17.11とともに、namedの脆弱なバージョンが上記の欠陥を発生させる不正な形式のIXFRを受信すると、転送されたセカンダリゾーンが次回リフレッシュされるときに、namedプロセスがアサーションチェックの失敗により終了します。(CVE-2021-25214)

- BIND 9.0.0 -> 9.11.29、 9.12.0 -> 9.16.13、およびバージョンBIND 9.9.3-S1 -> 9.11.29-S1および9.16.8-S1 -> 9.16.13-S1のBIND Supported Preview Edition、ならびにBIND 9.17開発ブランチのリリースバージョン9.17.0 -> 9.17.11とともに、namedの脆弱なバージョンが上記の欠陥を発生させるレコードのクエリを受け取ると、namedプロセスがアサーションチェックの失敗により終了します。この脆弱性は、現在維持されているすべてのBIND 9ブランチ(9.11、9.11-S、9.16、9.16-S、9.17)およびBIND 9の他のすべてのバージョンに影響を与えます。(CVE-2021-25215)

- BIND 9.5.0 -> 9.11.29、9.12.0 -> 9.16.13、およびバージョンBIND 9.11.3-S1 -> 9.11.29-S1および9.16.8-S1 -> 9.16.13-S1のBIND Supported Preview Editionだけでなく、リリースバージョン9.17.0 - > 9.17.1のBINDの9.17開発ブランチでは、BINDサーバーが影響を受けるバージョンを実行していて、GSS-TSIG機能を使用するように設定されている場合に脆弱です。BINDのデフォルト設定を使用する構成では、脆弱なコードパスは公開されませんが、tkey-gssapi-keytabまたはtkey-gssapi-credential構成オプションの有効な値を明示的に設定することで、サーバーが脆弱になる可能性があります。デフォルトの構成は脆弱ではありませんが、GSS-TSIGは、BINDがSambaと統合されているネットワークや、BINDサーバーをActive Directoryドメインコントローラーと組み合わせる混合サーバー環境で頻繁に使用されています。これらの条件を満たすサーバーの場合、ISC SPNEGOの実装は、BINDが構築されたCPUアーキテクチャに応じて、さまざまな攻撃に脆弱です。64ビットプラットフォーム用にコンパイルされたnamedバイナリの場合、この欠陥を利用してバッファオーバーリードがトリガーされ、サーバークラッシュが引き起こされる可能性があります。32ビットプラットフォーム用にコンパイルされたnamedバイナリの場合、バッファオーバーフローによりサーバーがクラッシュし、リモートコード実行も達成される可能性があります。弊社は、標準のSPNEGO実装がMITおよびHeimdal Kerberosライブラリで利用可能であると判断しました。これらのライブラリは、幅広いオペレーティングシステムをサポートしているため、ISCの実装を不必要かつ古いものにします。したがって、BINDユーザーに対する攻撃対象領域を減らすために、BIND 9.11および9.16の4月のリリースにあるISC SPNEGOの実装を削除します(これは、すでにBIND 9.17からドロップされていました)。通常、BINDの安定したESV(拡張サポートバージョン)から何かを削除することはありませんが、システムライブラリはISC SPNEGOの実装を置き換えることができるため、安定性とセキュリティの理由からこの場合は例外としました。(CVE-2021-25216)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://ubuntu.com/security/notices/USN-4929-1

プラグインの詳細

深刻度: Critical

ID: 149092

ファイル名: ubuntu_USN-4929-1.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2021/4/30

更新日: 2021/5/13

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2021-25216

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, cpe:/o:canonical:ubuntu_linux:21.04, p-cpe:/a:canonical:ubuntu_linux:bind9, p-cpe:/a:canonical:ubuntu_linux:bind9-dev, p-cpe:/a:canonical:ubuntu_linux:bind9-dnsutils, p-cpe:/a:canonical:ubuntu_linux:bind9-host, p-cpe:/a:canonical:ubuntu_linux:bind9-libs, p-cpe:/a:canonical:ubuntu_linux:bind9-utils, p-cpe:/a:canonical:ubuntu_linux:bind9utils, p-cpe:/a:canonical:ubuntu_linux:dnsutils, p-cpe:/a:canonical:ubuntu_linux:host, p-cpe:/a:canonical:ubuntu_linux:libbind-dev, p-cpe:/a:canonical:ubuntu_linux:libbind-export-dev, p-cpe:/a:canonical:ubuntu_linux:libbind9-140, p-cpe:/a:canonical:ubuntu_linux:libbind9-160, p-cpe:/a:canonical:ubuntu_linux:libdns-export1100, p-cpe:/a:canonical:ubuntu_linux:libdns-export1100-udeb, p-cpe:/a:canonical:ubuntu_linux:libdns-export162, p-cpe:/a:canonical:ubuntu_linux:libdns-export162-udeb, p-cpe:/a:canonical:ubuntu_linux:libdns1100, p-cpe:/a:canonical:ubuntu_linux:libdns162, p-cpe:/a:canonical:ubuntu_linux:libirs-export141, p-cpe:/a:canonical:ubuntu_linux:libirs-export141-udeb, p-cpe:/a:canonical:ubuntu_linux:libirs-export160, p-cpe:/a:canonical:ubuntu_linux:libirs-export160-udeb, p-cpe:/a:canonical:ubuntu_linux:libirs141, p-cpe:/a:canonical:ubuntu_linux:libirs160, p-cpe:/a:canonical:ubuntu_linux:libisc-export160, p-cpe:/a:canonical:ubuntu_linux:libisc-export160-udeb, p-cpe:/a:canonical:ubuntu_linux:libisc-export169, p-cpe:/a:canonical:ubuntu_linux:libisc-export169-udeb, p-cpe:/a:canonical:ubuntu_linux:libisc160, p-cpe:/a:canonical:ubuntu_linux:libisc169, p-cpe:/a:canonical:ubuntu_linux:libisccc-export140, p-cpe:/a:canonical:ubuntu_linux:libisccc-export140-udeb, p-cpe:/a:canonical:ubuntu_linux:libisccc-export160, p-cpe:/a:canonical:ubuntu_linux:libisccc-export160-udeb, p-cpe:/a:canonical:ubuntu_linux:libisccc140, p-cpe:/a:canonical:ubuntu_linux:libisccc160, p-cpe:/a:canonical:ubuntu_linux:libisccfg-export140, p-cpe:/a:canonical:ubuntu_linux:libisccfg-export140-udeb, p-cpe:/a:canonical:ubuntu_linux:libisccfg-export160, p-cpe:/a:canonical:ubuntu_linux:libisccfg-export160-udeb, p-cpe:/a:canonical:ubuntu_linux:libisccfg140, p-cpe:/a:canonical:ubuntu_linux:libisccfg160, p-cpe:/a:canonical:ubuntu_linux:liblwres141, p-cpe:/a:canonical:ubuntu_linux:liblwres160, p-cpe:/a:canonical:ubuntu_linux:lwresd

必要な KB アイテム: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/4/29

脆弱性公開日: 2021/4/29

参照情報

CVE: CVE-2021-25214, CVE-2021-25215, CVE-2021-25216

USN: 4929-1

IAVA: 2021-A-0206