PHP 7.4.x < 7.4.18 / 8.x < 8.0.5 整数オーバーフロー

high Nessus プラグイン ID 149348
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、整数オーバーフロー状態の影響を受けます。

説明

リモートホストにインストールされているPHPのバージョンは、7.4.18より前の7.4.x、または8.0.5より前の8.xです。したがって、pnctl_exec()の整数オーバーフロー状態の影響を受けます。攻撃者がこれを悪用し、サービス拒否(DoS)状態や任意のコードの実行を引き起こす可能性があります。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョンにのみ依存しています。

ソリューション

PHPバージョン7.4.18または8.0.5以降にアップグレードしてください。

関連情報

https://www.php.net/ChangeLog-7.php#7.4.18

https://www.php.net/ChangeLog-8.php#8.0.5

プラグインの詳細

深刻度: High

ID: 149348

ファイル名: php_8_0_5.nasl

バージョン: 1.2

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/5/7

更新日: 2021/6/3

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: manual

CVSS スコアの根本的理由: Score based on analysis of vendor advisory.

CVSS v2

リスクファクター: Medium

Base Score: 6.8

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: High

Base Score: 8.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/PHP

パッチ公開日: 2021/4/29

脆弱性公開日: 2021/4/29

参照情報

IAVA: 2021-A-0210-S