openSUSEセキュリティ更新プログラム:webkit2gtk3 (openSUSE-2021-637)

critical Nessus プラグイン ID 149570

言語:

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

この webkit2gtk3 用更新プログラムでは、以下の問題を修正します :

- バージョン 2.32.0 に更新してください(bsc#1184155):

- URL がポートを省略した場合の認証リクエストポートを修正します。

- メインフレームが非同期でスクロールされる際の iframe スクロールを修正します

- スクロールモード。

- g_memdup の使用を停止します。

- のシグナルハンドラーをオーバーライドする際に警告メッセージを表示します

- スレッドの中断。

- GCC 11 の RISC-V のビルドを修正します。

- 複数のクラッシュおよびレンダリングの問題を修正します。

- セキュリティ修正:CVE-2021-1788、CVE-2021-1844、CVE-2021-1871

- バージョン 2.30.6 の更新 (bsc#1184262) :

- Google ドキュメントと Google ドライブのユーザーエージェントの不具合を再度更新します。

- 複数のクラッシュおよびレンダリングの問題を修正します。

- セキュリティ修正:CVE-2020-27918、CVE-2020-29623、CVE-2021-1765 CVE-2021-1789、CVE-2021-1799、CVE-2021-1801、CVE-2021-1870。

- armv6/armv7 の _constraints を更新します (bsc#1182719)

- 2.32.0 で削除された NPAPI プラグインサポートを復元します

この更新はSUSEからインポートされました:SLE-15-SP2: 更新プロジェクトを更新します。

ソリューション

影響を受けるwebkit2gtk3パッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1182719

https://bugzilla.opensuse.org/show_bug.cgi?id=1184155

https://bugzilla.opensuse.org/show_bug.cgi?id=1184262

プラグインの詳細

深刻度: Critical

ID: 149570

ファイル名: openSUSE-2021-637.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2021/5/18

更新日: 2022/5/5

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2021-1871

VPR

リスクファクター: Critical

スコア: 9.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:libjavascriptcoregtk-4_0-18, p-cpe:/a:novell:opensuse:libjavascriptcoregtk-4_0-18-32bit, p-cpe:/a:novell:opensuse:libjavascriptcoregtk-4_0-18-32bit-debuginfo, p-cpe:/a:novell:opensuse:libjavascriptcoregtk-4_0-18-debuginfo, p-cpe:/a:novell:opensuse:libwebkit2gtk-4_0-37, p-cpe:/a:novell:opensuse:libwebkit2gtk-4_0-37-32bit, p-cpe:/a:novell:opensuse:libwebkit2gtk-4_0-37-32bit-debuginfo, p-cpe:/a:novell:opensuse:libwebkit2gtk-4_0-37-debuginfo, p-cpe:/a:novell:opensuse:libwebkit2gtk3-lang, p-cpe:/a:novell:opensuse:typelib-1_0-JavaScriptCore-4_0, p-cpe:/a:novell:opensuse:typelib-1_0-WebKit2-4_0, p-cpe:/a:novell:opensuse:typelib-1_0-WebKit2WebExtension-4_0, p-cpe:/a:novell:opensuse:webkit-jsc-4, p-cpe:/a:novell:opensuse:webkit-jsc-4-debuginfo, p-cpe:/a:novell:opensuse:webkit2gtk-4_0-injected-bundles, p-cpe:/a:novell:opensuse:webkit2gtk-4_0-injected-bundles-debuginfo, p-cpe:/a:novell:opensuse:webkit2gtk3-debugsource, p-cpe:/a:novell:opensuse:webkit2gtk3-devel, p-cpe:/a:novell:opensuse:webkit2gtk3-minibrowser, p-cpe:/a:novell:opensuse:webkit2gtk3-minibrowser-debuginfo, cpe:/o:novell:opensuse:15.2

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/4/30

脆弱性公開日: 2020/12/8

CISAの既知の悪用日: 2021/11/17, 2022/5/25

参照情報

CVE: CVE-2020-27918, CVE-2020-29623, CVE-2021-1765, CVE-2021-1788, CVE-2021-1789, CVE-2021-1799, CVE-2021-1801, CVE-2021-1844, CVE-2021-1870, CVE-2021-1871