PostgreSQL 9.6.x < 9.6.22/10.x < 10.17/11.x < 11.12/12.x < 12.7/13.x < 13.3の複数の脆弱性

high Nessus プラグイン ID 149850

概要

リモートのデータベースサーバーは、複数の脆弱性の影響を受けます

説明

リモートホストにインストールされているPostgreSQLのバージョンは、9.6.22より前の9.6、10.17より前の10、11.12より前の11、12.7より前の12、13.3より前の13です。したがって、次の複数の脆弱性による影響を受ける可能性があります。

-配列サブスクリプト計算における整数オーバーフローによるバッファオーバーラン(CVE-2021-32027)

-INSERT ...におけるメモリ漏洩ON CONFLICT ... DO UPDATE(CVE-2021-32028)

-パーティションテーブルのUPDATE ...におけるメモリ漏洩RETURNING(CVE-2021-32029)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

PostgreSQL 9.6.22 / 10.17 / 11.12 / 12.7 / 13.3 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?d682c4df

http://www.postgresql.org/support/security/CVE-2021-32029/

http://www.postgresql.org/support/security/CVE-2021-32028/

http://www.postgresql.org/support/security/CVE-2021-32027/

プラグインの詳細

深刻度: High

ID: 149850

ファイル名: postgresql_20210513.nasl

バージョン: 1.6

タイプ: local

ファミリー: Databases

公開日: 2021/5/24

更新日: 2022/4/11

リスク情報

CVSS スコアのソース: CVE-2021-32027

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 4.8

ベクトル: AV:N/AC:L/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:postgresql:postgresql

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/5/13

脆弱性公開日: 2021/5/13

参照情報

CVE: CVE-2021-32027, CVE-2021-32028, CVE-2021-32029

IAVB: 2021-B-0036-S