Apache 2.4.x < 2.4.47の複数の脆弱性

critical Nessus プラグイン ID 150280

概要

リモートのWebサーバーは複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているApache httpdのバージョンは、2.4.47より前です。したがって、2.4.47の変更ログに記載されている複数の脆弱性の影響を受けます:

-「MergeSlashes OFF」との予期しない<Location>セクションマッチング(CVE-2021-30641)

- mod_auth_digest:ダイジェストノンスの検証中に1 NULバイトのスタックオーバーフローが発生する可能性があります。(CVE-2020-35452)

- mod_session:NULLポインターデリファレンスによるクラッシュの可能性を修正します。これが悪用され、悪意のあるバックエンドサーバーとSessionHeaderによるサービス拒否が引き起こされる可能性があります。(CVE-2021-26691)

- mod_session:NULLポインターデリファレンスによるクラッシュの可能性を修正します。これが悪用され、サービス拒否が引き起こされる可能性があります。
(CVE-2021-26690)

- mod_proxy_http:NULLポインターデリファレンスによるクラッシュの可能性を修正します。これが悪用され、サービス拒否が引き起こされる可能性があります。(CVE-2020-13950)

- Windows:ローカルユーザーがhttpdプロセスを停止できないようにします(CVE-2020-13938)

- mod_proxy_wstunnel、mod_proxy_http:アップグレード可能なプロトコルのエンドツーエンドのネゴシエーションを処理します。(CVE-2019-17567)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apacheをバージョン2.4.47以降にアップグレードしてください。

参考資料

https://downloads.apache.org/httpd/CHANGES_2.4

プラグインの詳細

深刻度: Critical

ID: 150280

ファイル名: apache_2_4_47.nasl

バージョン: 1.5

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2021/6/4

更新日: 2022/4/11

設定: 徹底したチェックを有効にする

サポートされているセンサー: Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2021-26691

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要な KB アイテム: installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/6/1

脆弱性公開日: 2021/6/1

参照情報

CVE: CVE-2019-17567, CVE-2020-13938, CVE-2020-13950, CVE-2020-35452, CVE-2021-26690, CVE-2021-26691, CVE-2021-30641

IAVA: 2021-A-0259-S