RHEL 7:postgresql(RHSA-2021:2397)

high Nessus プラグイン ID 150756
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのRed Hatホストにセキュリティ更新プログラムが適用されていません。

説明

リモートのRedhat Enterprise Linux 7ホストにインストールされているパッケージは、RHSA-2021:2397アドバイザリに記載されている複数の脆弱性の影響を受けます。

- postgresql:配列サブスクリプト計算における整数オーバーフローによるバッファオーバーラン(CVE-2021-32027)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/119.html

https://cwe.mitre.org/data/definitions/190.html

https://access.redhat.com/security/cve/CVE-2021-32027

https://access.redhat.com/errata/RHSA-2021:2397

https://bugzilla.redhat.com/1956876

プラグインの詳細

深刻度: High

ID: 150756

ファイル名: redhat-RHSA-2021-2397.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2021/6/14

更新日: 2021/10/7

依存関係: ssh_get_info.nasl, redhat_repos.nasl

リスク情報

CVSS スコアのソース: CVE-2021-32027

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 4.8

ベクトル: AV:N/AC:L/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:postgresql, p-cpe:/a:redhat:enterprise_linux:postgresql-contrib, p-cpe:/a:redhat:enterprise_linux:postgresql-devel, p-cpe:/a:redhat:enterprise_linux:postgresql-docs, p-cpe:/a:redhat:enterprise_linux:postgresql-libs, p-cpe:/a:redhat:enterprise_linux:postgresql-plperl, p-cpe:/a:redhat:enterprise_linux:postgresql-plpython, p-cpe:/a:redhat:enterprise_linux:postgresql-pltcl, p-cpe:/a:redhat:enterprise_linux:postgresql-server, p-cpe:/a:redhat:enterprise_linux:postgresql-static, p-cpe:/a:redhat:enterprise_linux:postgresql-test, p-cpe:/a:redhat:enterprise_linux:postgresql-upgrade

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/6/14

脆弱性公開日: 2021/5/13

参照情報

CVE: CVE-2021-32027

RHSA: 2021:2397

IAVB: 2021-B-0036-S

CWE: 119, 190