Apache Tomcat 10.0.0-M1 < 10.0.2の複数の脆弱性

high Nessus プラグイン ID 150856

概要

リモートのApache Tomcatサーバーは、複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているTomcatのバージョンは10.0.2より前です。したがって、fixed_in_apache_tomcat_10.0.2_security-10のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- Apache Tomcatバージョン10.0.0-M1~10.0.0-M4、9.0.0.M1~9.0.34、8.5.0~8.5.54、および7.0.0~7.0.103を使用するときには、a)攻撃者がサーバー上のファイルのコンテンツと名前を制御できる場合、b)サーバーがFileStoreでPersistenceManagerを使用するように構成されている場合、c)PersistenceManagerが、sessionAttributeValueClassNameFilter=null(SecurityManagerが使用されていない場合のデフォルト)を使用して構成されているか、または攻撃者が指定したオブジェクトを逆シリアル化できる十分に緩いフィルターを使用して構成されている場合、およびd)攻撃者が、FileStoreによって使用されるストレージの場所から攻撃者の管理下にあるファイルまでの相対ファイルパスを把握している場合に、攻撃者が特別に細工したリクエストを使用して、管理下のファイルの逆シリアル化によってリモートコード実行をトリガーできます。攻撃が成功するには、a)~d)のすべての条件がtrueである必要があることに注意してください。(CVE-2020-9484)

- CVE-2020-9484の修正が不完全でした。Apache Tomcat 10.0.0-M1~10.0.0、9.0.0.M1~9.0.41、8.5.0~8.5.61または7.0.0~7.0.107を使用される可能性が非常に低い構成エッジケースと共に使用する場合、Tomcatインスタンスは依然としてCVE-2020-9494に対して脆弱でした。注意:以前に公開されたCVE-2020-9484の前提条件と以前に公開されたCVE-2020-9484の緩和策の両方が、この問題にも適用されます。(CVE-2021-25329)

- 新しいh2c接続リクエストに応答する際、Apache Tomcatバージョン10.0.0-M1から10.0.0、9.0.0.M1から9.0.41、および8.5.0から8.5.61は、あるリクエストからのリクエストヘッダー、および限られた量のリクエスト本文を複写する可能性があります。つまり、ユーザーAとユーザーBの両方が、ユーザーAのリクエストの結果を確認する可能性があるということです。
(CVE-2021-25122)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache Tomcatバージョン10.0.2以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?6ed8976b

http://www.nessus.org/u?d7b0c6a5

http://www.nessus.org/u?b2e22528

プラグインの詳細

深刻度: High

ID: 150856

ファイル名: tomcat_10_0_2.nasl

バージョン: 1.6

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2021/6/17

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-25122

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

脆弱性公開日: 2020/5/11

参照情報

CVE: CVE-2020-9484, CVE-2021-25122, CVE-2021-25329

IAVA: 2020-A-0225-S, 2020-A-0324, 2021-A-0114-S