CodeMeterランタイムのバッファオーバーリード(WIBU-210423-01)

critical Nessus プラグイン ID 150962

概要

ライセンスサーバーにバッファオーバーリードの脆弱性があります。

説明

リモートのCodeMeterランタイムネットワークサーバーは、ユーザー指定のデータの検証が不十分なため、バッファオーバーリードの脆弱性による影響を受けます。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたメッセージを介して、ヒープメモリコンテンツを漏洩させたりサーバーをクラッシュさせたりする可能性があります。

ソリューション

CodeMeter Runtimeをバージョン7.21a以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?70853191

プラグインの詳細

深刻度: Critical

ID: 150962

ファイル名: codemeter_cve-2021-20093.nbin

バージョン: 1.16

タイプ: remote

ファミリー: SCADA

公開日: 2021/6/23

更新日: 2022/8/15

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 5.2

CVSS v2

リスクファクター: Medium

Base Score: 6.4

Temporal Score: 5

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-20093

CVSS v3

リスクファクター: Critical

Base Score: 9.1

Temporal Score: 8.2

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:wibu:codemeter_runtime

必要な KB アイテム: Services/codemeter_network_server

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

Nessus によりエクスプロイト済み: true

パッチ公開日: 2021/6/10

脆弱性公開日: 2021/6/10

参照情報

CVE: CVE-2021-20093