Jenkins LTS < 2.289.2 / Jenkins weekly < 2.300の複数の脆弱性

medium Nessus プラグイン ID 151193

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーホストで実行されているアプリケーションは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートのWebサーバーで実行されているJenkinsのバージョンは、2.289.2より前のJenkins LTSまたは2.300より前のJenkins weeklyです。そのため、以下の複数の脆弱性の影響を受けます。

- Jenkinsの2.299 以前、LTS 2.289.1以前では、アイテム/読み取り権限がない場合でも、ユーザーがキューアイテムをキャンセルし、アイテム/キャンセルの権限があるジョブのビルドを中止できますJenkins 2.300、LTS 2.289.2 では、ユーザーがアイテム/キャンセル権限に加えて、該当するタイプのアイテム/読み取り権限を持つ必要があります。Jenkinsの以前のバージョンでの回避策として、アイテム/読み取り権限を持たないユーザーにアイテム/キャンセル権限を付与しないでください。(CVE-2021-21670)

- Jenkinsの 2.299以前、LTSの2.289.1以前では、ログイン時に既存のセッションが無効になることはありません。これにより、攻撃者がソーシャルエンジニアリング技術を使用して、Jenkinsへの管理者アクセス権を取得する可能性があります。この脆弱性は、Jenkins 2.266 およびLTS 2.277.1で持ち込まれした。Jenkins 2.300、LTS 2.289.2 は、ログイン時に既存のセッションを無効にします。注:問題が発生した場合、管理者はJavaシステムプロパティhudson.security.SecurityRealm.sessionFixationProtectionModeを2に設定することで異なる実装を選択することやそのシステムプロパティを0に設定することで修正を完全に無効にすることもできます。(CVE-2021-21671)

-Selenium HTML report Plugin 1.0 以前は、XML外部エンティティ(XXE)攻撃を防ぐためのXMLパーサーを構成していません。これにより、このプラグインを使用して解析されたレポートファイルを制御できる攻撃者が、Jenkinsコントローラーまたはサーバー側のリクエスト偽造から秘密を抽出するために外部エンティティを使用する細工されたレポートファイルをJenkinsに解析させる可能性があります。Selenium HTMLレポートプラグイン 1.1 は、XMLパーサーの外部エンティティ解決を無効にします。(CVE-2021-21672)

- CASプラグイン 1.6.0 以前は、ログイン後のリダイレクトURLが正当にJenkinsを指示していると不適切に判断します。これにより、攻撃者がフィッシング攻撃を実行し、ユーザーをJenkins URLに移動させ、認証成功後に別のサイトにユーザーを転送することがかのうです。CASプラグイン 1.6.1 は、相対(Jenkins)URLにのみリダイレクトします。(CVE-2021-21673)

-request-pluginプラグイン 2.2.6 以前は、HTTPエンドポイントで権限チェックを実行しません。これにより、Overall Read権限を持つ攻撃者が保留中のリクエストのリストを閲覧する可能性があります。requests-pluginプラグイン 2.2.7が保留中のリクエストのリストを表示するには、Overall/Read権限が必要です。(CVE-2021-21674)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Jenkins weeklyをバージョン2.300以降に、Jenkins LTSをバージョン2.289.2以降にアップグレードしてください

関連情報

https://jenkins.io/security/advisory/2021-06-30

プラグインの詳細

深刻度: Medium

ID: 151193

ファイル名: jenkins_2_300.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/6/30

更新日: 2021/7/23

依存関係: jenkins_detect.nasl

リスク情報

CVSS スコアのソース: CVE-2021-21673

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:cloudbees:jenkins, cpe:/a:jenkins:jenkins

必要な KB アイテム: www/Jenkins

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/6/30

脆弱性公開日: 2021/6/30

参照情報

CVE: CVE-2021-21670, CVE-2021-21671, CVE-2021-21672, CVE-2021-21673, CVE-2021-21674

IAVA: 2021-A-0335