OpenJDK 7 <= 7u211 / 8 <= 8u202 / 11.0.0 <= 11.0.2 / 12.0.0 <= 12.0.0複数の脆弱性(2019年4月16日)

high Nessus プラグイン ID 151214

概要

OpenJDKは複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているOpenJDKは、7 <= 7u211 / 8 <= 8u202 / 11.0.0 <= 11.0.2 / 12.0.0 <= 12.0.0より前です。したがって、2019年4月16日のアドバイザリに記載されている複数の脆弱性の影響を受けます。

注意:Java CVEには常にOpenJDKバージョンが含まれているとは限りませんが、言及されているOpenJDKセキュリティアドバイザリのパッチバージョンを使用してTenableによって個別に確認されます。

- Oracle Java SEのJava SEコンポーネントの脆弱性(サブコンポーネント:2D)。サポートされているバージョンで影響を受けるのは、Java SE:7u211および8u202。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Java SEを侵害する可能性があります。この脆弱性への攻撃が成功した場合、Java SEの乗っ取りが発生する可能性があります。注:この脆弱性が該当するのは、通常サンドボックス化されたJava Web Startアプリケーションまたはサンドボックス化されたJavaアプレットを(Java SE 8で)実行しているクライアントで、信頼できないコード(インターネットからのコードなど)を読み込んで実行し、セキュリティについてはJavaサンドボックスに依存しているJavaデプロイメントです。この脆弱性は、通常サーバーで信頼できるコード(管理者がインストールしたコードなど)のみを読み込んで実行するJavaデプロイメントには存在しません。CVSS 3.0 ベーススコア 8.1(機密性、整合性、可用性の影響)CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)。
(CVE-2019-2698)

- Java SE、Oracle Java SEのJava SE Embeddedコンポーネントの脆弱性(サブコンポーネント:ライブラリ)。
サポートされているバージョンで影響を受けるのは、Java SE:7u211、8u202、11.0.2 および12; Java SE Embedded:8u201。
容易に悪用可能な脆弱性を利用して、認証されていない攻撃者が複数のプロトコルを介してネットワークにアクセスし、Java SEやJava SE Embeddedを侵害する可能性があります。この脆弱性を利用した攻撃に成功すると、権限なしにJava SEとJava SE Embeddedをハングさせたり、頻繁にクラッシュを繰り返したりする(完全なDOS)可能性があります。注:この脆弱性は、信頼できないJava Web Startアプリケーションや信頼できないJavaアプレットを、たとえばWebサービスを介して使用せずに、指定されたコンポーネントのAPIにデータを提供することでのみ悪用される可能性があります。CVSS 3.0ベーススコア7.5(可用性に影響)。CVSS Vector:
(CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)。(CVE-2019-2602)

- Java SE、Oracle Java SEのJava SE Embeddedコンポーネントの脆弱性(サブコンポーネント:RMI)。サポートされているバージョンで影響を受けるのは、Java SE:7u211、8u202、11.0.2 および12; Java SE Embedded:8u201。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを介してネットワークにアクセスし、Java SE、Java SE Embeddedを侵害する可能性があります。この脆弱性に対する攻撃が成功すると、重要なデータやJava SE、Java SE Embeddedがアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があります。注:この脆弱性が該当するのは、通常サンドボックス化されたJava Web Startアプリケーションまたはサンドボックス化されたJavaアプレットを(Java SE 8で)実行しているクライアントで、信頼できないコード(インターネットからのコードなど)を読み込んで実行し、セキュリティについてはJavaサンドボックスに依存しているJavaデプロイメントです。この脆弱性は、指定されたコンポーネントでAPIを使用することによって(たとえばAPIにデータを提供するWebサービスを通して)悪用される可能性もあります。CVSS 3.0ベーススコア5.9(整合性への影響)CVSS Vector:
(CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N)。(CVE-2019-2684)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

7u211 / 8u202 / 11.0.2 / 12.0.0より後のOpenJDKにアップグレードしてください

関連情報

https://openjdk.java.net/groups/vulnerability/advisories/2019-04-16

プラグインの詳細

深刻度: High

ID: 151214

ファイル名: openjdk_2019-04-16.nasl

バージョン: 1.4

タイプ: local

エージェント: windows, macosx, unix

ファミリー: Misc.

公開日: 2021/7/6

更新日: 2022/4/11

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2019-2698

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:oracle:openjdk

必要な KB アイテム: installed_sw/Java

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

脆弱性公開日: 2019/4/16

参照情報

CVE: CVE-2019-2602, CVE-2019-2684, CVE-2019-2698