Joomla 2.5.x < 3.9.28 Multiple Vulnerabilities (5840-joomla-3-9-28)

medium Nessus プラグイン ID 151429

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPアプリケーションは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートのWebサーバーで実行されているJoomla!のインスタンスは3.9.28より前の2.5.xです。したがって、複数の脆弱性の影響を受けます。

-JForm APIのRulesフィールドでの不適切なエスケープにより、XSSの脆弱性が引き起こされます。(CVE-2021-26035)

-入力の検証がないため、usergroupsテーブルが破損する可能性があります。(CVE-2021-26036)

-ユーザーのパスワードが変更された時、またはユーザーがブロックされた時に、さまざまなCMS機能が既存のユーザーセッションを適切に終了しませんでした。(CVE-2021-26037)

-com_installerのインストールアクションに、スーパーユーザーに対して必要なハードコードされたACLチェックが欠落しているため、さまざまな攻撃ベクトルが発生する可能性があります。デフォルトのシステムは影響を受けません。デフォルトでは、com_installerはすでにスーパーユーザーに制限されています。(CVE-2021-26038)

-com_mediaのimagelistビューでの不適切なエスケープにより、XSS脆弱性が引き起こされます。(CVE-2021-26039)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Joomla!をバージョン3.9.28以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?ff811b28

http://www.nessus.org/u?cc18b6c6

http://www.nessus.org/u?ea3ca23f

http://www.nessus.org/u?64f5301e

http://www.nessus.org/u?5b69b338

http://www.nessus.org/u?bf612487

プラグインの詳細

深刻度: Medium

ID: 151429

ファイル名: joomla_3928.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/7/7

更新日: 2021/7/12

依存関係: joomla_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2021-26037

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:a:joomla:joomla\\\!:*:*:*:*:*:*:*:*

必要な KB アイテム: www/PHP, Settings/ParanoidReport, installed_sw/Joomla!

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/7/6

脆弱性公開日: 2021/7/6

参照情報

CVE: CVE-2021-26035, CVE-2021-26036, CVE-2021-26037, CVE-2021-26038, CVE-2021-26039