Apache Tomcat 7.0.x<= 7.0.108/ 8.5.x<= 8.5.65/ 9.0.x<= 9.0.45/ 10.0.x<= 10.0.5の脆弱性

medium Nessus プラグイン ID 151502

概要

リモートのApache Tomcatサーバーは、脆弱性の影響を受けます。

説明

リモートホストにインストールされているTomcatのバージョンは 7.0.x<= 7.0.108/ 8.5.x<= 8.5.65/ 9.0.x<= 9.0.45/ 10.0.x<= 10.0.5です。したがって、fixed_in_apache_tomcat_10.0.6_security-10のアドバイザリに記載されている脆弱性の影響を受けます。

- JNDI Realmによって行われるクエリが、常にパラメーターを適切にエスケープするとは限りませんでした。パラメーター値は、管理者が提供した構成データだけでなく、ユーザーが提供したデータ (ユーザー名など) から入力される可能性があります。限られた状況で、ユーザーがさまざまなユーザー名を使用して認証を行ったり、LockOut Realmが提供する一部の保護をバイパスしたりすることが可能でした。 (CVE-2021-30640)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache Tomcat バージョン 7.0.109、8.5.66、9.0.46、10.0.6 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?d3fb2d8e

http://www.nessus.org/u?0fb6f5ab

http://www.nessus.org/u?0d761c19

http://www.nessus.org/u?ddfa2b5e

http://www.nessus.org/u?95156892

http://www.nessus.org/u?ed08487c

http://www.nessus.org/u?806274b5

http://www.nessus.org/u?f104a57d

https://bz.apache.org/bugzilla/show_bug.cgi?id=65224

http://www.nessus.org/u?837a9443

プラグインの詳細

深刻度: Medium

ID: 151502

ファイル名: tomcat_10_0_6.nasl

バージョン: 1.6

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2021/7/12

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.7

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-30640

CVSS v3

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 5.7

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

参照情報

CVE: CVE-2021-30640