Drupal 7.x < 7.82 / 8.9.x < 8.9.17 / 9.1.x < 9.1.11 / 9.2.x < 9.2.2 Drupalの脆弱性(SA-CORE-2021-004)

high Nessus プラグイン ID 151932
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPアプリケーションは、脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートのWebサーバーで実行されているDrupalのインスタンスは、7.82より前の7.x、8.9.17より前の8.9.x、9.1.11より前の9.1.x、または9.2.2より前の9.2.xです。したがって、脆弱性の影響を受けます。

- Drupalプロジェクトは、ピアArchive_Tarライブラリを使用します。Archive_Tarは、Drupalに影響するセキュリティ更新プログラムをリリースしました。DrupalコアによるArchive_Tarライブラリの使用ではシンボリックリンクを許可しないため脆弱ではないので、この脆弱性は緩和されます。contribまたはカスタムコードがこのライブラリを使用して、潜在的に信頼できないソースからのtarアーカイブ(.tar、.tar.gz、.bz2、.tlzなど)を抽出する場合、悪用される可能性があります。このアドバイザリは、Drupal Stewardの対象ではありません。(CVE-2021-32610)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Drupalバージョン7.82/8.9.17/9.1.11/9.2.2以降にアップグレードしてください。

関連情報

https://www.drupal.org/sa-core-2021-004

https://www.drupal.org/project/drupal/releases/7.82

https://www.drupal.org/project/drupal/releases/8.9.17

https://www.drupal.org/project/drupal/releases/9.1.11

https://www.drupal.org/project/drupal/releases/9.2.2

https://www.drupal.org/steward

プラグインの詳細

深刻度: High

ID: 151932

ファイル名: drupal_9_2_2.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/7/22

更新日: 2021/8/19

依存関係: drupal_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2021-32610

VPR

リスクファクター: Medium

スコア: 5.2

CVSS v2

リスクファクター: Low

Base Score: 3.6

Temporal Score: 2.7

ベクトル: AV:L/AC:L/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.1

Temporal Score: 6.2

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:drupal:drupal

必要な KB アイテム: installed_sw/Drupal, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/7/21

脆弱性公開日: 2021/7/21

参照情報

CVE: CVE-2021-32610

IAVA: 2021-A-0353-S