GitLab 10.5 < 13.10.5 / 13.11 < 13.11.5 / 13.12 < 13.12.2 (CVE-2021-22214)

high Nessus プラグイン ID 152483

概要

リモートホストにインストールされている GitLab のバージョンは、脆弱性の影響を受けます。

説明

リモートホストにインストールされている GitLab のバージョンは、以下の脆弱性の影響を受けます:

- 内部ネットワークへの Webhook のリクエストが有効になっている場合、登録が制限されている GitLab インスタンス上でも、10.5 以降の GitLab CE/EE のバージョンすべてに影響するサーバーサイドリクエスト偽造の脆弱性が存在し、認証されていない攻撃者によって悪用される可能性がありました。(CVE-2021-22214)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

GitLab バージョン 13.10.5、13.11.5、13.12.2 以降にアップグレードしてください。

参考資料

http://www.nessus.org/u?5a77584e

https://gitlab.com/gitlab-org/gitlab/-/issues/322926

https://hackerone.com/reports/1110131

プラグインの詳細

深刻度: High

ID: 152483

ファイル名: gitlab_cve-2021-22214.nbin

バージョン: 1.47

タイプ: combined

エージェント: unix

ファミリー: Misc.

公開日: 2021/8/11

更新日: 2024/6/13

サポートされているセンサー: Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.2

CVSS v2

リスクファクター: Medium

基本値: 4.3

現状値: 3.4

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS スコアのソース: CVE-2021-22214

CVSS v3

リスクファクター: High

基本値: 8.6

現状値: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:gitlab:gitlab

必要な KB アイテム: installed_sw/GitLab

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/6/8

脆弱性公開日: 2021/6/8

参照情報

CVE: CVE-2021-22214