Apple iTunes < 12.11.4 複数の脆弱性(uncredentialed check)

high Nessus プラグイン ID 152752

概要

リモートホストにインストールされているアプリケーションは、複数の脆弱性の影響を受けます

説明

リモートのWindowsホストにインストールされているApple iTunesのバージョンは、12.11.4より前です。したがって、HT212609のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- バッファオーバーフローが、境界チェックを改善することで対処されました。この問題は、iOS 14.7、macOS Big Sur 11.5、watchOS 7.6、tvOS 14.7、セキュリティ更新2021-004 Catalinaで修正されています。悪意のある細工がされた画像を処理すると、任意のコードが実行される可能性があります。(CVE-2021-30785)

- チェックを改善することで、この問題に対処しました。この問題は、 iOS 14.7、macOS Big Sur 11.5、watchOS 7.6、tvOS 14.7で修正されています。悪意のある細工がされた画像を処理すると、任意のコードが実行される可能性があります。
(CVE-2021-30779)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apple iTunesバージョン12.11.4以降にアップグレードしてください。

関連情報

https://support.apple.com/en-us/HT212609

プラグインの詳細

深刻度: High

ID: 152752

ファイル名: itunes_12_11_4_banner.nasl

バージョン: 1.5

タイプ: remote

ファミリー: Peer-To-Peer File Sharing

公開日: 2021/8/23

更新日: 2021/9/24

リスク情報

CVSS スコアのソース: CVE-2021-30785

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apple:itunes

必要な KB アイテム: installed_sw/iTunes DAAP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/8/10

脆弱性公開日: 2021/7/21

参照情報

CVE: CVE-2021-30779, CVE-2021-30785

APPLE-SA: HT212609, APPLE-SA-2021-08-10