Ubuntu 20.04 LTS:Linuxカーネル脆弱性(USN-5072-1)

high Nessus プラグイン ID 153179
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートUbuntuホストに1つ以上のセキュリティ更新がありません。

説明

リモートのUbuntu 20.04 LTSホストには、USN-5072-1のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- SVMネスト化仮想化をサポートするための欠陥がKVMのAMDコードで見つかりました。この欠陥は、ネストされたゲスト(L2)を生成/処理するためにL1ゲストによって提供されたVMCB(仮想マシン制御ブロック)を処理する際に発生します。int_ctlフィールドの不適切な検証が原因で、この問題により、悪意のあるL1がL2ゲストに対してAVICサポート(Advanced Virtual Interrupt Controller)を有効にする可能性があります。その結果、L2ゲストがホストの物理ページを読み書きできるようになり、システム全体のクラッシュ、機密データの漏洩、またはゲストからホストへのエスケープが発生する可能性があります。この欠陥は、5.14-rc7より前のLinuxカーネルバージョンに影響を与えます。(CVE-2021-3653)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://ubuntu.com/security/notices/USN-5072-1

プラグインの詳細

深刻度: High

ID: 153179

ファイル名: ubuntu_USN-5072-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2021/9/9

更新日: 2021/10/12

依存関係: ssh_get_info.nasl, linux_alt_patch_detect.nasl

リスク情報

CVSS スコアのソース: CVE-2021-3656

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:canonical:ubuntu_linux:20.04:-:lts:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-oem-20.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-oem-20.04-edge:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-oem-20.04b:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-cloud-tools-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-headers-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-headers-oem-20.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-modules-extra-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-oem-20.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-tools-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-tools-oem-20.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-headers-oem-20.04-edge:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-headers-oem-20.04b:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-oem-20.04-edge:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-oem-20.04b:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-oem-5.10-tools-host:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-tools-oem-20.04-edge:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-tools-oem-20.04b:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-azure-5.8-cloud-tools-5.8.0-1041:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-azure-5.8-headers-5.8.0-1041:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-azure-5.8-tools-5.8.0-1041:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-buildinfo-5.10.0-1045-oem:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-buildinfo-5.8.0-1041-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-cloud-tools-5.8.0-1041-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-headers-5.10.0-1045-oem:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-headers-5.8.0-1041-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-5.10.0-1045-oem:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-5.8.0-1041-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-unsigned-5.10.0-1045-oem:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-image-unsigned-5.8.0-1041-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-modules-5.10.0-1045-oem:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-modules-5.8.0-1041-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-modules-extra-5.8.0-1041-azure:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-oem-5.10-headers-5.10.0-1045:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-oem-5.10-tools-5.10.0-1045:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-tools-5.10.0-1045-oem:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:linux-tools-5.8.0-1041-azure:*:*:*:*:*:*:*

必要な KB アイテム: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/9/8

脆弱性公開日: 2021/9/8

参照情報

CVE: CVE-2021-3656, CVE-2021-3653

USN: 5072-1