SUSE SLES15セキュリティ更新プログラム: カーネル (SUSE-SU-2021:3177-1)

high Nessus プラグイン ID 153535

Language:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートの SUSE Linux SLES15ホストには、SUSE-SU-2021:3177-1 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 5.13.7以前の Linux カーネルで、保護機構はBPFスタックに初期化されていないメモリロケーションの可能性を無視するので、権限のない BPF プログラムが投機ストアバイパスサイドチャネル攻撃を介して、カーネルメモリから機密情報を入手することができます。(CVE-2021-34556)

- 5.13.7以前の Linux カーネルで、特定のプリエンプション処理のストア動作は、必ずしも攻撃者の管理下にある値を持つストア動作の前に発生しないため、権限のない BPF プログラムが投機ストアバイパスサイドチャネル攻撃を介して、カーネルメモリから機密情報を入手することができます。
(CVE-2021-35477)

- Linux カーネル HCI サブシステムの関数 sco_sock_sendmsg() のメモリ解放後使用 (Use-After-Free) の欠陥が、ユーザーが ioct UFFDIO_REGISTER を呼び出す方法や、期待される sco_sock_sendmsg() 呼び出しとともに予期されている制御可能な障害のあるメモリページで sco_conn_del() 呼び出しの競合状態をトリガーする他の方法で見つかりました。権限のあるローカルユーザーはこの欠陥を利用して、システムをクラッシュしたり、システム上で権限を昇格したりする可能性があります。
(CVE-2021-3640)

- SVM ネスト化仮想化をサポートするための欠陥が KVM の AMD コードで見つかりました。この欠陥は、ネストされたゲスト (L2) を生成/処理するために L1 ゲストによって提供された VMCB (仮想マシン制御ブロック) を処理する際に発生します。int_ctl フィールドの不適切な検証が原因で、この問題により、悪意のある L1 が L2 ゲストに対して AVIC サポート (Advanced Virtual Interrupt Controller) を有効にする可能性があります。その結果、L2 ゲストがホストの物理ページを読み書きできるようになり、システム全体のクラッシュ、機密データの漏洩、またはゲストからホストへのエスケープが発生する可能性があります。この欠陥は、5.14-rc7 より前の Linux カーネルバージョンに影響を与えます。(CVE-2021-3653)

- SVM ネスト化仮想化をサポートするための欠陥が KVM の AMD コードで見つかりました。この欠陥は、ネストされたゲスト (L2) を生成/処理するために L1 ゲストによって提供された VMCB (仮想マシン制御ブロック) を処理する際に発生します。virt_ext フィールドの検証が不適切なために、この問題により、悪意のある L1 が、L2 ゲストの VMLOAD/VMSAVE インターセプトと VLS (仮想 VMLOAD/VMSAVE) の両方を無効にする可能性があります。その結果、L2 ゲストがホストの物理ページを読み書きできるようになり、システム全体のクラッシュ、機密データの漏洩、またはゲストからホストへのエスケープが発生する可能性があります。(CVE-2021-3656)

- 5.14-rc3 より前のバージョンの Linux カーネルのトレースモジュール機能における CPU 応答の欠如が、ユーザーがトレースリングバッファを使用する特定の方法で見つかりました。権限を持つローカルユーザー (CAP_SYS_ADMIN 機能あり) だけがこの欠陥を利用して、リソースを枯渇させ、サービス拒否を引き起こす可能性があります。
(CVE-2021-3679)

- Linux カーネルの OverlayFS サブシステムに、ユーザーが OverlayFS で TmpFS ファイルシステムをマウントする方法に、欠陥が見つかりました。この欠陥により、ローカルユーザーはアクセスできないはずの隠しファイルにアクセスできます。(CVE-2021-3732)

- Linux カーネルの fs/btrfs/volumes.c の btrfs_rm_device 関数に NULL ポインターデリファレンスの欠陥が見つかりました。このバグを発生させるには CAP_SYS_ADMIN が必要です。この欠陥により、ローカルの攻撃者がシステムをクラッシュさせたり、カーネルの内部情報を漏洩したりする可能性があります。この脆弱性が最大の脅威となるのは、システムの可用性です。(CVE-2021-3739)

- Linux カーネルの Qualcomm IPC ルータープロトコルに、領域外 (OOB) メモリ読み取りの欠陥が見つかりました。
サニタリーチェックが欠落すると、ローカルの攻撃者が領域外メモリにアクセスし、システムクラッシュや内部カーネル情報の漏洩を引き起こす可能性があります。この脆弱性が最大の脅威となるのは、システムの可用性です。 (CVE-2021-3743)

- Linux カーネルの drivers/tty/vt/vt_ioctl.c の vt_k_ioctl で競合問題が発生しました。これにより、vc_mode への書き込みアクセスが lock-in vt_ioctl (KDSETMDE) で保護されていないため、vt で領域外読み取りが発生する可能性があります。この脆弱性による主な脅威は、データの機密性に関するものです。(CVE-2021-3753)

- memcg サブシステムの Linux カーネルの ipc 機能に、ユーザーが semget 関数を複数回呼び出してセマフォを作成する方法に、メモリオーバーフローの脆弱性が見つかりました。この欠陥により、ローカルユーザーがリソースを枯渇させ、サービス拒否を引き起こす可能性があります。この脆弱性が最大の脅威となるのは、システムの可用性です。 (CVE-2021-3759)

- **異論あり** 5.13.4 より前の Linux カーネルの drivers/char/virtio_console.c において、データ破損や損失が、バッファサイズを超える buf-> LEN 値を入力する信頼できないデバイスによって誘発される可能性があります。注意:
ベンダーは、引用されているデータ破損が、既存の任意のユースケースで、脆弱性ではないと指摘している。長さ検証が追加されたのは、ホスト OS の異常な動作に直面した際の堅牢性のみを目的としていたからです。
(CVE-2021-38160)

- 5.12.11より前の Linux カーネルの arch/x86/kvm/mmu/paging_tmpl.h は、シャドウページのアクセス権限を誤って計算し、欠落しているゲストの保護ページ障害を引き起こします。(CVE-2021-38198)

- 5.13.6以前の Linux カーネルのdrivers/usb/host/max3421-hcd.c により、物理的に接近した攻撃者が、特定の状況でMAX-3421 USBデバイスを取り外すことで、サービス拒否(メモリ解放後使用およびパニック) を引き起こす可能性があります。(CVE-2021-38204)

- 5.13.3 以前の Linux カーネルの drivers/net/ethernet/xilinx/xilinx_emaclite.c は、カーネルポインター (つまり、実際の IOMEM ポインター) を出力するため、攻撃者が ASLR 保護メカニズムを無効にするのを容易にします。(CVE-2021-38205)

- 5.12.13より前の Linux カーネルのdrivers/net/ethernet/xilinx/ll_temac_main.c により、リモート攻撃者は、約 10 分間大量のネットワークトラフィックを送信することによって、サービス拒否(オーバーフローおよびやロックアップ) を引き起こすことができます。(CVE-2021-38207)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

https://bugzilla.suse.com/1040364

https://bugzilla.suse.com/1127650

https://bugzilla.suse.com/1135481

https://bugzilla.suse.com/1152489

https://bugzilla.suse.com/1160010

https://bugzilla.suse.com/1167032

https://bugzilla.suse.com/1168202

https://bugzilla.suse.com/1174969

https://bugzilla.suse.com/1175052

https://bugzilla.suse.com/1175543

https://bugzilla.suse.com/1177399

https://bugzilla.suse.com/1180141

https://bugzilla.suse.com/1180347

https://bugzilla.suse.com/1181148

https://bugzilla.suse.com/1181972

https://bugzilla.suse.com/1184114

https://bugzilla.suse.com/1184180

https://bugzilla.suse.com/1185675

https://bugzilla.suse.com/1185902

https://bugzilla.suse.com/1186264

https://bugzilla.suse.com/1186731

https://bugzilla.suse.com/1187211

https://bugzilla.suse.com/1187455

https://bugzilla.suse.com/1187468

https://bugzilla.suse.com/1187619

https://bugzilla.suse.com/1188067

https://bugzilla.suse.com/1188172

https://bugzilla.suse.com/1188418

https://bugzilla.suse.com/1189057

https://bugzilla.suse.com/1189077

https://bugzilla.suse.com/1189153

https://bugzilla.suse.com/1189197

https://bugzilla.suse.com/1189209

https://bugzilla.suse.com/1189210

https://bugzilla.suse.com/1189212

https://bugzilla.suse.com/1189213

https://bugzilla.suse.com/1189214

https://bugzilla.suse.com/1189215

https://bugzilla.suse.com/1189216

https://bugzilla.suse.com/1189217

https://bugzilla.suse.com/1189218

https://bugzilla.suse.com/1189219

https://bugzilla.suse.com/1189220

https://bugzilla.suse.com/1189221

https://bugzilla.suse.com/1189222

https://bugzilla.suse.com/1189229

https://bugzilla.suse.com/1189262

https://bugzilla.suse.com/1189291

https://bugzilla.suse.com/1189292

https://bugzilla.suse.com/1189298

https://bugzilla.suse.com/1189301

https://bugzilla.suse.com/1189305

https://bugzilla.suse.com/1189323

https://bugzilla.suse.com/1189384

https://bugzilla.suse.com/1189385

https://bugzilla.suse.com/1189392

https://bugzilla.suse.com/1189399

https://bugzilla.suse.com/1189400

https://bugzilla.suse.com/1189427

https://bugzilla.suse.com/1189449

https://bugzilla.suse.com/1189503

https://bugzilla.suse.com/1189504

https://bugzilla.suse.com/1189505

https://bugzilla.suse.com/1189506

https://bugzilla.suse.com/1189507

https://bugzilla.suse.com/1189562

https://bugzilla.suse.com/1189563

https://bugzilla.suse.com/1189564

https://bugzilla.suse.com/1189565

https://bugzilla.suse.com/1189566

https://bugzilla.suse.com/1189567

https://bugzilla.suse.com/1189568

https://bugzilla.suse.com/1188439

https://bugzilla.suse.com/1188616

https://bugzilla.suse.com/1188780

https://bugzilla.suse.com/1188781

https://bugzilla.suse.com/1188782

https://bugzilla.suse.com/1188783

https://bugzilla.suse.com/1188784

https://bugzilla.suse.com/1188786

https://bugzilla.suse.com/1188787

https://bugzilla.suse.com/1188788

https://bugzilla.suse.com/1188790

https://bugzilla.suse.com/1188878

https://bugzilla.suse.com/1188885

https://bugzilla.suse.com/1188924

https://bugzilla.suse.com/1188982

https://bugzilla.suse.com/1188983

https://bugzilla.suse.com/1188985

https://bugzilla.suse.com/1189021

https://bugzilla.suse.com/1189569

https://bugzilla.suse.com/1189573

https://bugzilla.suse.com/1189574

https://bugzilla.suse.com/1189575

https://bugzilla.suse.com/1189576

https://bugzilla.suse.com/1189577

https://bugzilla.suse.com/1189579

https://bugzilla.suse.com/1189581

https://bugzilla.suse.com/1189582

https://bugzilla.suse.com/1189583

https://bugzilla.suse.com/1189585

https://bugzilla.suse.com/1189586

https://bugzilla.suse.com/1189587

https://bugzilla.suse.com/1189706

https://bugzilla.suse.com/1189760

https://bugzilla.suse.com/1189832

https://bugzilla.suse.com/1189841

https://bugzilla.suse.com/1189870

https://bugzilla.suse.com/1189883

https://bugzilla.suse.com/1190025

https://bugzilla.suse.com/1190115

https://bugzilla.suse.com/1190117

https://bugzilla.suse.com/1190131

https://bugzilla.suse.com/1190181

https://www.suse.com/security/cve/CVE-2021-34556

https://www.suse.com/security/cve/CVE-2021-35477

https://www.suse.com/security/cve/CVE-2021-3640

https://www.suse.com/security/cve/CVE-2021-3653

https://www.suse.com/security/cve/CVE-2021-3656

https://www.suse.com/security/cve/CVE-2021-3679

https://www.suse.com/security/cve/CVE-2021-3732

https://www.suse.com/security/cve/CVE-2021-3739

https://www.suse.com/security/cve/CVE-2021-3743

https://www.suse.com/security/cve/CVE-2021-3753

https://www.suse.com/security/cve/CVE-2021-3759

https://www.suse.com/security/cve/CVE-2021-38160

https://www.suse.com/security/cve/CVE-2021-38198

https://www.suse.com/security/cve/CVE-2021-38204

https://www.suse.com/security/cve/CVE-2021-38205

https://www.suse.com/security/cve/CVE-2021-38207

http://www.nessus.org/u?6a2f7ec0

プラグインの詳細

深刻度: High

ID: 153535

ファイル名: suse_SU-2021-3177-1.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2021/9/22

更新日: 2023/7/13

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.6

ベクトル: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2021-38160

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

CVSS スコアのソース: CVE-2021-3656

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:cluster-md-kmp-rt, p-cpe:/a:novell:suse_linux:dlm-kmp-rt, p-cpe:/a:novell:suse_linux:gfs2-kmp-rt, p-cpe:/a:novell:suse_linux:kernel-devel-rt, p-cpe:/a:novell:suse_linux:kernel-rt, p-cpe:/a:novell:suse_linux:kernel-rt-devel, p-cpe:/a:novell:suse_linux:kernel-rt_debug, p-cpe:/a:novell:suse_linux:kernel-rt_debug-devel, p-cpe:/a:novell:suse_linux:kernel-source-rt, p-cpe:/a:novell:suse_linux:kernel-syms-rt, p-cpe:/a:novell:suse_linux:ocfs2-kmp-rt, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/9/21

脆弱性公開日: 2021/8/2

参照情報

CVE: CVE-2021-34556, CVE-2021-35477, CVE-2021-3640, CVE-2021-3653, CVE-2021-3656, CVE-2021-3679, CVE-2021-3732, CVE-2021-3739, CVE-2021-3743, CVE-2021-3753, CVE-2021-3759, CVE-2021-38160, CVE-2021-38198, CVE-2021-38204, CVE-2021-38205, CVE-2021-38207

SuSE: SUSE-SU-2021:3177-1