Apache >= 2.4.30 < 2.4.49 mod_proxy_uwsgi

high Nessus プラグイン ID 153586
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは脆弱性の影響を受けます。

説明

リモートホストにインストールされているApache httpdのバージョンは、2.4.30より後かつ2.4.49より前です。したがって、2.4.49の変更ログに記載されている脆弱性の影響を受けます。注意深く細工されたリクエストuri-pathにより、mod_proxy_uwsgiが割り当てられたメモリを超えて読み取り、クラッシュ(DoS)する可能性があります。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apacheバージョン2.4.49以降にアップグレードしてください。

関連情報

https://downloads.apache.org/httpd/CHANGES_2.4

https://httpd.apache.org/security/vulnerabilities_24.html

プラグインの詳細

深刻度: High

ID: 153586

ファイル名: apache_mod_proxy_uwsgi_2_4_49.nasl

バージョン: 1.4

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2021/9/23

更新日: 2021/9/29

依存関係: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2021-36160

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要な KB アイテム: installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/9/16

脆弱性公開日: 2021/9/16

参照情報

CVE: CVE-2021-36160

IAVA: 2021-A-0440