Ubuntu 16.04 LTS/18.04 LTS/20.04 LTS/21.04:Vimの脆弱性(USN-5093-1)

high Nessus プラグイン ID 153779
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートUbuntuホストに1つ以上のセキュリティ更新がありません。

説明

リモートのUbuntu 16.04 LTS/18.04 LTS/20.04 LTS/21.04ホストには、USN-5093-1のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- vimはヒープベースのバッファオーバーフローに対して脆弱です(CVE-2021-3770、CVE-2021-3778)

- vimはメモリ解放後使用(Use After Free)に対して脆弱です(CVE-2021-3796)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://ubuntu.com/security/notices/USN-5093-1

プラグインの詳細

深刻度: High

ID: 153779

ファイル名: ubuntu_USN-5093-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2021/9/29

更新日: 2021/10/15

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2021-3796

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.3

Temporal Score: 6.4

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:21.04, p-cpe:/a:canonical:ubuntu_linux:vim, p-cpe:/a:canonical:ubuntu_linux:vim-athena, p-cpe:/a:canonical:ubuntu_linux:vim-athena-py2, p-cpe:/a:canonical:ubuntu_linux:vim-common, p-cpe:/a:canonical:ubuntu_linux:vim-gnome, p-cpe:/a:canonical:ubuntu_linux:vim-gnome-py2, p-cpe:/a:canonical:ubuntu_linux:vim-gtk, p-cpe:/a:canonical:ubuntu_linux:vim-gtk-py2, p-cpe:/a:canonical:ubuntu_linux:vim-gtk3, p-cpe:/a:canonical:ubuntu_linux:vim-gtk3-py2, p-cpe:/a:canonical:ubuntu_linux:vim-gui-common, p-cpe:/a:canonical:ubuntu_linux:vim-lesstif, p-cpe:/a:canonical:ubuntu_linux:vim-nox, p-cpe:/a:canonical:ubuntu_linux:vim-nox-py2, p-cpe:/a:canonical:ubuntu_linux:vim-runtime, p-cpe:/a:canonical:ubuntu_linux:vim-tiny, p-cpe:/a:canonical:ubuntu_linux:xxd

必要な KB アイテム: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/9/28

脆弱性公開日: 2021/9/6

参照情報

CVE: CVE-2021-3770, CVE-2021-3778, CVE-2021-3796

USN: 5093-1