Ubuntu 18.04 LTS:blの脆弱性(USN-5098-1)

medium Nessus プラグイン ID 153856
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートUbuntuホストにセキュリティ更新がありません。

説明

リモートのUbuntu 18.04 LTSホストには、USN-5098-1のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

-bl <4.0.3、<3.0.1、<2.2.1、および <1.2.3にバッファオーバーリードの脆弱性が存在し、これにより、攻撃者が、consume()引数で終わり、負の値になる可能性がある場合に、BufferListの状態が破損する可能性があるユーザー入力(タイプされたものでも)を提供し、騙して正規の .slice()呼び出しで初期化されていないメモリを漏洩する可能性があります。(CVE-2020-8244)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるnode-blパッケージを更新してください。

関連情報

https://ubuntu.com/security/notices/USN-5098-1

プラグインの詳細

深刻度: Medium

ID: 153856

ファイル名: ubuntu_USN-5098-1.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2021/10/4

更新日: 2021/10/4

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-8244

VPR

リスクファクター: Low

スコア: 2.5

CVSS v2

リスクファクター: Medium

Base Score: 6.4

Temporal Score: 4.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 5.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:node-bl

必要な KB アイテム: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/9/30

脆弱性公開日: 2020/8/30

参照情報

CVE: CVE-2020-8244

USN: 5098-1