Jenkins EnterpriseおよびOperations Center < 2.289.3.2 rev 2の不適切な権限(CloudBeesセキュリティアドバイザリ2021年8月2日)

low Nessus プラグイン ID 153978

概要

リモートのWebサーバーでホストされているジョブスケジューリング/管理システムは、不適切な権限の脆弱性の影響を受けます。

説明

リモートのWebサーバーで実行されているJenkins EnterpriseまたはJenkins Operations Centerのバージョンは、2.289.3.2 rev 2より前の2.xです。したがって、CasCバンドルを使用するとき、脆弱性の影響を受けます。新しいビルドステップにより、「ADMIN」権限のないユーザーがCasCバンドルを削除できます。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Jenkins EnterpriseまたはJenkins Operations Centerをバージョン2.289.3.2 rev 2以降にアップグレードしてください。

関連情報

https://www.cloudbees.com/cloudbees-security-advisory-2021-08-02

プラグインの詳細

深刻度: Low

ID: 153978

ファイル名: cloudbees_security_advisory_2021-08-02.nasl

バージョン: 1.2

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: CGI abuses

公開日: 2021/10/11

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアの根本的理由: Based on analysis of vendor advisory.

CVSS v2

リスクファクター: Low

Base Score: 1.7

ベクトル: AV:L/AC:L/Au:S/C:N/I:P/A:N

CVSS スコアのソース: manual

CVSS v3

リスクファクター: Low

Base Score: 3.3

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

脆弱性情報

CPE: cpe:/a:cloudbees:jenkins

必要な KB アイテム: installed_sw/Jenkins

パッチ公開日: 2021/8/2

脆弱性公開日: 2021/8/2