Adobe Reader < 17.011.30204/20.004.30017/21.007.20099の複数の脆弱性(APSB21-104)(macOS)

high Nessus プラグイン ID 154154

概要

リモートのmacOSホストにインストールされているAdobe Readerのバージョンは、複数の脆弱性の影響を受けます。

説明

リモートのmacOSホストにインストールされているAdobe Readerのバージョンは、17.011.30204以前、20.004.30017以前、または21.007.20099以前です。したがって、複数の脆弱性の影響を受けます。

- Adobe Acrobat Reader DCバージョン21.007.20095以前、21.007.20096以前、20.004.30015以前、17.011.30202以前は、細工されたJPEG2000ファイルを解析する際に、領域外書き込みの脆弱性の影響を受けます。これにより、現在のユーザーのコンテキストで任意のコードが実行される可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。
(CVE-2021-40731)

- Adobe Acrobat Reader DCバージョン21.007.20095以前、21.007.20096以前、20.004.30015以前、17.011.30202以前は、グローバルオブジェクトウィンドウのGetURL関数を処理する際に、メモリ解放後使用(Use-After-Free)の脆弱性の影響を受けます。これにより現行ユーザーのコンテキストで任意コード実行に至る可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2021-40728)

- Adobe Acrobat Reader DCバージョン21.007.20095以前、21.007.20096以前、20.004.30015以前、17.011.30202以前は、領域外読み取りの脆弱性の影響を受けます。これにより、秘密メモリーの漏洩を引き起こす可能性があります。攻撃者がこの脆弱性を利用し、ASLRのような緩和策をバイパスする可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるPDFファイルを開く必要があります。(CVE-2021-40729)

- Adobe Acrobat Reader DCバージョン21.007.20095以前、21.007.20096以前、20.004.30015以前、17.011.30202以前は、メモリ解放後使用(Use-After-Free)の影響を受けます。これにより、リモート攻撃者が影響を受けるAdobe Acrobat Reader DCのインストールに関する機密情報を漏洩する可能性があります。標的となるユーザーが悪意のあるページにアクセスするか、悪意のあるファイルを開く必要があるため、この脆弱性を悪用するにはユーザーの操作が必要です。JPG2000の画像の解析に特定の欠陥が存在します。(CVE-2021-40730)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Adobe Reader バージョン 17.011.30204/20.004.30017/21.007.20099 またはそれ以降にアップグレードしてください。

関連情報

https://cwe.mitre.org/data/definitions/125.html

https://cwe.mitre.org/data/definitions/416.html

https://cwe.mitre.org/data/definitions/787.html

https://helpx.adobe.com/security/products/acrobat/apsb21-104.html

プラグインの詳細

深刻度: High

ID: 154154

ファイル名: macos_adobe_reader_apsb21-104.nasl

バージョン: 1.7

タイプ: local

エージェント: macosx

公開日: 2021/10/14

更新日: 2022/1/27

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2021-40731

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.9

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7.5

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:adobe:acrobat_reader

必要な KB アイテム: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Reader

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/10/12

脆弱性公開日: 2021/10/12

参照情報

CVE: CVE-2021-40728, CVE-2021-40729, CVE-2021-40730, CVE-2021-40731

IAVA: 2021-A-0458-S

CWE: 125, 416, 787