PHP 8.0.x < 8.0.12

high Nessus プラグイン ID 154296

概要

リモートの Web サーバーで実行されている PHP のバージョンは、脆弱性の影響を受けます。

説明

リモートホストにインストールされているPHPのバージョンは、8.0.12より前のバージョンです。したがって、バージョン8.0.12のアドバイザリに記載されている脆弱性の影響を受けます。

- PHPバージョン7.3.xの7.3.31までおよび7.4.25より下の7.4.xそして8.0.12より下の8.0.xでは、rootとして実行しているメインFPMデーモンプロセスおよびより低い権限のユーザーとして実行している子ワーカープロセスでPHP FPM SAPIを実行する場合、子プロセスがメインプロセスと共有されているメモリにアクセスし、メインプロセスに書き込むことが可能です。これにより、rootプロセスが無効なメモリの読み取りと書き込みを行うように変更され、権限のないローカルユーザーからrootユーザーに権限が昇格される可能性があります。
(CVE-2021-21703)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

PHP バージョン 8.0.12 以降にアップグレードしてください。

関連情報

http://bugs.php.net/81026

http://php.net/ChangeLog-8.php#8.0.12

プラグインの詳細

深刻度: High

ID: 154296

ファイル名: php_8_0_12.nasl

バージョン: 1.7

タイプ: remote

ファミリー: CGI abuses

公開日: 2021/10/21

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.9

Temporal Score: 5.1

ベクトル: AV:L/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-21703

CVSS v3

リスクファクター: High

Base Score: 7

Temporal Score: 6.1

ベクトル: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/10/21

脆弱性公開日: 2021/10/21

参照情報

CVE: CVE-2021-21703

IAVA: 2021-A-0503