SUSE SLES15 セキュリティ更新プログラム: tomcat (SUSE-SU-2021:3669-1)

medium Nessus プラグイン ID 155462

言語:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートの SUSE Linux SLES15ホストには、SUSE-SU-2021:3669-1のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- Apache TomcatのJNDIレルムの脆弱性により、攻撃者が、有効なユーザー名のさまざまなバリエーションを使用して認証したり、LockOutレルムによって提供される保護の一部をバイパスしたりする可能性があります。この問題は、Apache Tomcat 10.0.0-M1〜10.0.5、9.0.0.M1~9.0.45、8.5.0~8.5.65に影響を与えます。(CVE-2021-30640)

- Apache Tomcat 10.0.0-M1~10.0.6、9.0.0.M1~9.0.46、および8.5.0~8.5.66が、一部の状況でHTTP転送エンコーディングリクエストヘッダーを正しく解析しませんでした。これにより、リバースプロキシで使用したときにスマグリングがリクエストされる可能性があります。詳細:- クライアントがHTTP/1.0応答のみを受け入れると宣言した場合、Tomcatは転送エンコーディングヘッダーを誤って無視しました。- Tomcatは識別エンコーディングを尊重していました。
- Tomcatは、チャンクエンコーディングがある場合に、それが最終エンコーディングであることを保証していませんでした。
(CVE-2021-33037)

- Apache Tomcat 8.5.0~8.5.63、9.0.0-M1~9.0.43および10.0.0-M1~10.0.2は、着信TLSパケットを適切に検証しませんでした。TomcatがTLSに対してNIO + OpenSSLまたはNIO2 + OpenSSLを使用するように構成されている場合、特別に細工されたパケットが使用されて無限ループがトリガーされ、サービス拒否が発生する可能性があります。
(CVE-2021-41079)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://bugzilla.suse.com/1188278

https://bugzilla.suse.com/1188279

https://bugzilla.suse.com/1190558

http://www.nessus.org/u?f7a24a53

https://www.suse.com/security/cve/CVE-2021-30640

https://www.suse.com/security/cve/CVE-2021-33037

https://www.suse.com/security/cve/CVE-2021-41079

プラグインの詳細

深刻度: Medium

ID: 155462

ファイル名: suse_SU-2021-3669-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2021/11/17

更新日: 2022/1/26

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-30640

CVSS v3

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 5.7

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:tomcat, p-cpe:/a:novell:suse_linux:tomcat-admin-webapps, p-cpe:/a:novell:suse_linux:tomcat-el-3_0-api, p-cpe:/a:novell:suse_linux:tomcat-jsp-2_3-api, p-cpe:/a:novell:suse_linux:tomcat-lib, p-cpe:/a:novell:suse_linux:tomcat-servlet-4_0-api, p-cpe:/a:novell:suse_linux:tomcat-webapps, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/11/16

脆弱性公開日: 2021/3/10

参照情報

CVE: CVE-2021-30640, CVE-2021-33037, CVE-2021-41079

SuSE: SUSE-SU-2021:3669-1

IAVA: 2021-A-0303-S