ThinkPHP < 5.0.24 RCE

high Nessus プラグイン ID 155964

概要

リモートWebサーバーは、リモートでコードが実行される脆弱性の影響を受けます。

説明

リモートホストにインストールされている ThinkPhP のバージョンは 5.0.24 より前です。したがって、リモートコード実行の脆弱性の影響を受けます。認証されていないリモート攻撃者がこの脆弱性を悪用し、複数のパラメーターを通して任意の php コードを実行する可能性があります。

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

ThinkPHP バージョン 5.0.24 以降にアップグレードしてください。

関連情報

https://www.exploit-db.com/exploits/48333

https://github.com/xiayulei/open_source_bms/issues/33

http://www.nessus.org/u?7be44ca0

プラグインの詳細

深刻度: High

ID: 155964

ファイル名: thinkphp_5_0_24.nasl

バージョン: 1.6

タイプ: remote

ファミリー: Web Servers

公開日: 2021/12/10

更新日: 2022/4/26

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 8.1

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2019-9082

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 8.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:thinkphp:thinkphp

必要な KB アイテム: installed_sw/ThinkPHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/2/24

脆弱性公開日: 2021/2/24

CISAの既知の悪用日: 2022/5/3

エクスプロイト可能

Metasploit (ThinkPHP Multiple PHP Injection RCEs)

参照情報

CVE: CVE-2019-9082