OpenSSL 3.0.0 < 3.0.1 の脆弱性

medium Nessus プラグイン ID 156100

概要

リモートサービスは脆弱性の影響を受けます。

説明

リモートホストにインストールされている OpenSSL は、3.0.1 より前のバージョンです。したがって、3.0.1のアドバイザリに記載されている脆弱性の影響を受けます。

- OpenSSL の libssl は、内部的にクライアント側の X509_verify_cert() を呼び出して、サーバーから提供された証明書を検証します。この関数は、内部エラー(メモリ不足など)を示すために負の戻り値を返す可能性があります。このような負の戻り値は OpenSSL によって誤って処理され、IO 関数(SSL_connect()またはSSL_do_handshake()など)が成功せず、その後の SSL_get_error() への呼び出しも実施されないため、SSL_ERROR_WANT_RETRY_VERIFY の値が返されます。この戻り値は、アプリケーションが以前に SSL_CTX_set_cert_verify_callback() を呼び出していた場合にのみ、OpenSSL によって返されることが想定されています。ほとんどのアプリケーションはこれを行わないため、SSL_GET_error() からの SSL_ERROR_WANT_RETRY_VERIFYの戻り値は完全に予期しないものになり、結果としてアプリケーションが正しく動作しない可能性があります。正確な動作はアプリケーションによって異なりますが、クラッシュ、無限ループ、またはその他の同様の不適切な応答を引き起こす可能性があります。
この問題は、証明書チェーンを処理する際に X509_verify_cert() が内部エラーを表示する OpenSSL 3.0 の別のバグと組み合わせされた場合、さらに深刻になります。これは、証明書に Subject Alternative Name 拡張が含まれておらず、認証局が名前の制約を強制している場合に発生します。この問題は、有効なチェーンでも発生する可能性があります。2 つの問題を組み合わせると、攻撃者は不適切なアプリケーション依存の動作を引き起こす可能性があります。OpenSSL 3.0.1 (3.0.0 が影響を受けます) で修正されました。 (CVE-2021-4044)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

OpenSSLのバージョン3.0.1以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?a7b84fa5

https://www.openssl.org/news/secadv/20211214.txt

プラグインの詳細

深刻度: Medium

ID: 156100

ファイル名: openssl_3_0_1.nasl

バージョン: 1.7

タイプ: remote

ファミリー: Web Servers

公開日: 2021/12/15

更新日: 2022/11/23

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-4160

CVSS v3

リスクファクター: Medium

Base Score: 5.9

Temporal Score: 5.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: openssl/port

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/12/14

脆弱性公開日: 2021/12/14

参照情報

CVE: CVE-2021-4044, CVE-2021-4160

IAVA: 2021-A-0602-S