RHEL 7 : xorg-x11-server (RHSA-2022:0003)

high Nessus プラグイン ID 156453

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 7ホストにインストールされているパッケージは、RHSA-2022: 0003 アドバイザリに記載されている複数の脆弱性の影響を受けます。

- xorg-x11-server: SProcRenderCompositeGlyphs の領域外アクセス (CVE-2021-4008)

- xorg-x11-server: SProcXFixesCreatePointerBarrier の領域外アクセス (CVE-2021-4009)

- xorg-x11-server: SProcScreenSaverSuspend の領域外アクセス (CVE-2021-4010)

- xorg-x11-server: SwapCreateRegister の領域外アクセス (CVE-2021-4011)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/119.html

https://access.redhat.com/security/cve/CVE-2021-4008

https://access.redhat.com/security/cve/CVE-2021-4009

https://access.redhat.com/security/cve/CVE-2021-4010

https://access.redhat.com/security/cve/CVE-2021-4011

https://access.redhat.com/errata/RHSA-2022:0003

https://bugzilla.redhat.com/2026059

https://bugzilla.redhat.com/2026072

https://bugzilla.redhat.com/2026073

https://bugzilla.redhat.com/2026074

プラグインの詳細

深刻度: High

ID: 156453

ファイル名: redhat-RHSA-2022-0003.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/1/3

更新日: 2022/4/26

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2021-4011

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:redhat:enterprise_linux:7:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-xdmx:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-xephyr:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-xnest:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-xorg:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-xvfb:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-common:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-source:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:xorg-x11-server-xwayland:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/1/3

脆弱性公開日: 2021/12/17

参照情報

CVE: CVE-2021-4008, CVE-2021-4009, CVE-2021-4010, CVE-2021-4011

CWE: 119

RHSA: 2022:0003