RHEL 7 : rh-nodejs14-nodejs および rh-nodejs14-nodejs-nodemon (RHSA-2022: 0041)

critical Nessus プラグイン ID 156548

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 7ホストにインストールされているパッケージは、RHSA-2022: 0041 アドバイザリに記載されている複数の脆弱性の影響を受けます。

-llhttp:ヘッダーのスペースによる HTTP リクエストスマグリング (CVE-2021-22959)

-llhttp:チャンクされたリクエストの本文を解析する際の HTTP リクエストスマグリング (CVE-2021-22960)

-nodejs-tar:シンボリックリンクを使用したディレクトリキャッシュポイズニングによるシンボリックリンク保護が不十分なため任意ファイルの作成と上書きが可能 (CVE-2021-37701、CVE-2021-37712)

-nodejs-ansi-regex:ANSI エスケープコードに一致する正規表現のサービス拒否 (ReDoS) (CVE-2021-3807)

-nodejs-json-schema:プロトタイプ汚染の脆弱性 (CVE-2021-3918)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/22.html

https://cwe.mitre.org/data/definitions/59.html

https://cwe.mitre.org/data/definitions/400.html

https://cwe.mitre.org/data/definitions/444.html

https://cwe.mitre.org/data/definitions/915.html

https://access.redhat.com/security/cve/CVE-2021-3807

https://access.redhat.com/security/cve/CVE-2021-3918

https://access.redhat.com/security/cve/CVE-2021-22959

https://access.redhat.com/security/cve/CVE-2021-22960

https://access.redhat.com/security/cve/CVE-2021-37701

https://access.redhat.com/security/cve/CVE-2021-37712

https://access.redhat.com/errata/RHSA-2022:0041

https://bugzilla.redhat.com/1999731

https://bugzilla.redhat.com/1999739

https://bugzilla.redhat.com/2007557

https://bugzilla.redhat.com/2014057

https://bugzilla.redhat.com/2014059

https://bugzilla.redhat.com/2024702

プラグインの詳細

深刻度: Critical

ID: 156548

ファイル名: redhat-RHSA-2022-0041.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/1/7

更新日: 2022/1/7

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2021-3918

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:rh-nodejs14-nodejs, p-cpe:/a:redhat:enterprise_linux:rh-nodejs14-nodejs-devel, p-cpe:/a:redhat:enterprise_linux:rh-nodejs14-nodejs-docs, p-cpe:/a:redhat:enterprise_linux:rh-nodejs14-nodejs-nodemon, p-cpe:/a:redhat:enterprise_linux:rh-nodejs14-npm

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/1/6

脆弱性公開日: 2021/8/31

参照情報

CVE: CVE-2021-3807, CVE-2021-3918, CVE-2021-22959, CVE-2021-22960, CVE-2021-37701, CVE-2021-37712

RHSA: 2022:0041

IAVB: 2021-B-0059

CWE: 22, 59, 400, 444, 915