Ubuntu 18.04LTS/20.04 LTS/21.10:strongSwanの脆弱性 (USN-5250-1)

critical Nessus プラグイン ID 157057

概要

リモートUbuntuホストにセキュリティ更新がありません。

説明

リモートの Ubuntu 18.04LTS / 20.04LTS / 21.10ホストには、USN-5250-1 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- 5.9.5より前の strongSwan で、悪意のあるレスポンダーが、実際にはクライアントを認証せずに、さらにはサーバー認証もない状態という早すぎるタイミングで EAP-Success メッセージを送信する可能性があります(IKEv2 用の相互認証および EAP-only 認証の EAP メソッドの場合)。(CVE-2021-45079)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://ubuntu.com/security/notices/USN-5250-1

プラグインの詳細

深刻度: Critical

ID: 157057

ファイル名: ubuntu_USN-5250-1.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/1/25

更新日: 2022/2/8

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2021-45079

VPR

リスクファクター: Medium

スコア: 5.2

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.1

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:21.10, p-cpe:/a:canonical:ubuntu_linux:charon-cmd, p-cpe:/a:canonical:ubuntu_linux:charon-systemd, p-cpe:/a:canonical:ubuntu_linux:libcharon-extauth-plugins, p-cpe:/a:canonical:ubuntu_linux:libcharon-extra-plugins, p-cpe:/a:canonical:ubuntu_linux:libcharon-standard-plugins, p-cpe:/a:canonical:ubuntu_linux:libstrongswan, p-cpe:/a:canonical:ubuntu_linux:libstrongswan-extra-plugins, p-cpe:/a:canonical:ubuntu_linux:libstrongswan-standard-plugins, p-cpe:/a:canonical:ubuntu_linux:strongswan, p-cpe:/a:canonical:ubuntu_linux:strongswan-charon, p-cpe:/a:canonical:ubuntu_linux:strongswan-libcharon, p-cpe:/a:canonical:ubuntu_linux:strongswan-nm, p-cpe:/a:canonical:ubuntu_linux:strongswan-pki, p-cpe:/a:canonical:ubuntu_linux:strongswan-scepclient, p-cpe:/a:canonical:ubuntu_linux:strongswan-starter, p-cpe:/a:canonical:ubuntu_linux:strongswan-swanctl, p-cpe:/a:canonical:ubuntu_linux:strongswan-tnc-base, p-cpe:/a:canonical:ubuntu_linux:strongswan-tnc-client, p-cpe:/a:canonical:ubuntu_linux:strongswan-tnc-ifmap, p-cpe:/a:canonical:ubuntu_linux:strongswan-tnc-pdp, p-cpe:/a:canonical:ubuntu_linux:strongswan-tnc-server

必要な KB アイテム: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/1/24

脆弱性公開日: 2022/1/24

参照情報

CVE: CVE-2021-45079

USN: 5250-1